Jump to content

Sky Slate Blueberry Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate

Documentation about OutputDebug and DebugView under Vista+


  • Please log in to reply
2 replies to this topic
  • Guests
  • Last active:
  • Joined: --
The documentation for OutputDebug should note that in WinVista and up, in order for DebugView to capture debug messages coming from AHK, its integrity level must be lowered like this:
icacls dbgview.exe /setintegritylevel low
The icacls command is included by default in Vista and up.

Without that little tweak, DebugView won't show any debug message coming from any AHK script either compiled or not.

See this forum topic for more details: <!-- m -->http://forum.sysinte... ... 10808.html<!-- m -->

Lexikos
  • Administrators
  • 9451 posts
  • Last active:
  • Joined: 17 Oct 2006
Interesting. I never had to do this on Windows 7, but I have UAC disabled. I have Vista and Windows 8 set up with default UAC settings in VirtualBox, so I thought I'd test on those. First, I copied the Dbgview.exe which I had on hand (4.76) and downloaded the latest version (4.79) to a shared location. These were my results on both VMs:

[*:3w1m6l9k]Running from the network share as standard user, 4.76 worked but 4.79 did not.
[*:3w1m6l9k]Running from the network share as administrator, both worked.
[*:3w1m6l9k]Copying to my desktop and running from there, both worked.
[*:3w1m6l9k]Setting low integrity level made no difference whatsoever.
After skimming through the thread you linked to (and having some background knowledge of integrity levels), I suppose that the low integrity level is only needed for receiving output from IE in protected mode, or other programs which run at low integrity level. Note that most apps (including AutoHotkey) run at medium or high integrity level.

  • Guests
  • Last active:
  • Joined: --
Well, on my Vista Home Premiun, as administrator, Dbgview 4.79 didn't show any debug message until I set its integrity level to low. So surely there are more factors in the equation.
That's why I suggest adding a quick note in the docs. Sooner or later there will be more people with the same problem as me.