Search found 1454 matches

by Xtra
Yesterday, 18:04
Forum: Ask For Help
Topic: How to have key function as normal but send an extra key on release?
Replies: 6
Views: 112

Re: How to have key function as normal but send an extra key on release?

Try this:

Code: Select all

#NoEnv

~j::return

~j Up::
    Sleep 200
    Send, {LAlt Down}
    Sleep 50
    Send, {LAlt Up}
return

4A 024 h d 2.39 j
4A 024 h u 0.13 j
A4 038 i d 0.20 LAlt
A4 038 i u 0.06 LAlt
Should be good now.
by Xtra
Yesterday, 02:55
Forum: Ask For Help
Topic: Passing parameters within the "run" command
Replies: 2
Views: 115

Re: Passing parameters within the "run" command

Take a look under 'Target' : Run
To pass parameters, add them immediately after the program or document name. If a parameter contains spaces, it is safest to enclose it in double quotes (even though it may work without them in some cases).
by Xtra
18 Nov 2019, 22:32
Forum: Ask For Help
Topic: How do we write a direct KEY in regedit?
Replies: 1
Views: 93

Re: How do we write a direct KEY in regedit?

Read: RegWrite
Depending where you are writing to you may need to have Admin rights and or run the script elevated.
Backup your Registry before making changes.

Use at your own risk.
by Xtra
18 Nov 2019, 22:24
Forum: Ask For Help
Topic: Merge 2 scripts in 1
Replies: 1
Views: 99

Re: Merge 2 scripts in 1

If you are not getting a response you should post your code in 'code boxes' here. Don't assume people want to download your scripts.
by Xtra
18 Nov 2019, 22:22
Forum: Ask For Help
Topic: A script that didn't work in other PC
Replies: 2
Views: 109

Re: A script that didn't work in other PC

Please post your script otherwise anyone trying to help you is just guessing what your script has in it.
by Xtra
18 Nov 2019, 22:17
Forum: Ask For Help
Topic: AHK toggle script help
Replies: 6
Views: 131

Re: AHK toggle script help

Code: Select all

#NoEnv

$Numpad1::Send, % (toggle1 := !toggle1) ? "{Numpad2}" : "{Numpad1}"
$Numpad3::Send, % (toggle3 := !toggle3) ? "{Numpad4}" : "{Numpad3}"
by Xtra
18 Nov 2019, 22:00
Forum: Ask For Help
Topic: Three ifs expressions Topic is solved
Replies: 3
Views: 106

Re: Three ifs expressions Topic is solved

Run this test script you can see the if/else checks are fine something else is wrong. $3:: one := true two := true three := false If (one) and (three) Gosub, sendA else If (one = false) and (two) Gosub, sendB else If (one) and (two = false) Gosub, sendA else If ((two) and (one) and (three = false)) ...
by Xtra
18 Nov 2019, 05:34
Forum: Ask For Help
Topic: How to have key function as normal but send an extra key on release?
Replies: 6
Views: 112

Re: How to have key function as normal but send an extra key on release?

Works fine here not sure why it wouldn't work.
I don't think those links apply.
Have you tried running only this as a script?
by Xtra
17 Nov 2019, 22:08
Forum: Ask For Help
Topic: Keybind to switch between loops
Replies: 4
Views: 150

Re: Keybind to switch between loops

Something different: #NoEnv SendMode Input SetWorkingDir %A_ScriptDir% ^w:: ^t::SetTimer, Looper, 100 ; 100ms change to suit loop time / delay ^z::Pause ; Toggle on / off ^x::ExitApp Looper() { static lastHotKey if (A_ThisHotkey != "^z") lastHotKey := A_ThisHotkey if (A_ThisHotkey = "^w" || lastHotK...
by Xtra
17 Nov 2019, 14:39
Forum: Ask For Help
Topic: How to have key function as normal but send an extra key on release?
Replies: 6
Views: 112

Re: How to have key function as normal but send an extra key on release?

Try:

Code: Select all

#NoEnv

~j::return

j Up::
    Sleep 200
    Send, {LAlt Down}
    Sleep 50
    Send, {LAlt Up}
return
by Xtra
16 Nov 2019, 19:42
Forum: Ask For Help
Topic: Bug? Abnormal order of evalutation in associative array
Replies: 3
Views: 143

Re: Bug? Abnormal order of evalutation in associative array

Before the object is created you are overwriting the vPath variable. This causes the values to be the same when the object is created. simplified example of variable overwriting: item := Object("key1",var:=1,"key2",var:=2,"key3",var:=3) msgbox % item.key1 " , " item.key2 " , " item.key3 Either chang...
by Xtra
16 Nov 2019, 06:10
Forum: Ask For Help
Topic: Script not running at the told speed
Replies: 4
Views: 185

Re: Script not running at the told speed

Read here: SetTimer PeriodOnOffDelete Default: If this parameter is blank and: 1) the timer does not exist: it will be created with a period of 250 . Timer precision: Due to the granularity of the OS's time-keeping system, Period is typically rounded up to the nearest multiple of 10 or 15.6 millisec...
by Xtra
15 Nov 2019, 16:30
Forum: Ask For Help
Topic: Sleep Function is not sleeping. Topic is solved
Replies: 5
Views: 519

Re: Sleep Function is not sleeping. Topic is solved

Could be getting interrupted from another Thread . Example: #NoEnv start := A_TickCount SetTimer, interupt, -250 Sleep 60000 MsgBox % A_TickCount - start ExitApp interupt: MsgBox, Sleep interrupt return Run and when message box is open double click ahk icon and look at the last executed lines.
by Xtra
14 Nov 2019, 23:06
Forum: Ask For Help
Topic: Having odd issues with ToolTip Topic is solved
Replies: 22
Views: 1067

Re: Having odd issues with ToolTip Topic is solved

Try this for your script.ahk #NoEnv #SingleInstance, On #Persistent ; ----------------- VARS ----------------- | global paused := False global stop := False OnMessage(0x5151, "MessageReceived") ; Handle messages from the window manager. SetTimer, status, 1000 ; ------------ SCRIPT COMMS ------------...
by Xtra
14 Nov 2019, 20:55
Forum: Ask For Help
Topic: Having odd issues with ToolTip Topic is solved
Replies: 22
Views: 1067

Re: Having odd issues with ToolTip Topic is solved

You should post your complete script so anyone can diagnose the issue. because simply opening this window is fixing the script. Sounds like your script only works when the ahk script window is active? Something fishy there. If I remove the include, I see nothing even if I refresh it while looping Ma...
by Xtra
14 Nov 2019, 20:23
Forum: Ask For Help
Topic: Having odd issues with ToolTip Topic is solved
Replies: 22
Views: 1067

Re: Having odd issues with ToolTip Topic is solved

Im going to assume you are double clicking the right ahk icon the receiver script not the sending/controller script?
One will not show what the other is doing. If you cant see the last executed lines something is wrong. Press F5 to refresh.
by Xtra
14 Nov 2019, 18:25
Forum: Ask For Help
Topic: Having odd issues with ToolTip Topic is solved
Replies: 22
Views: 1067

Re: Having odd issues with ToolTip Topic is solved

When the script is not working as intended double click the AHK icon in the system tray and see the last executed lines.
This should show where and why its stuck.
I would also changed the var named pause to something else as it is an AHK command. Try naming that var Paused instead.
by Xtra
14 Nov 2019, 16:19
Forum: General Discussion
Topic: Array-related terminology: values vs. elements
Replies: 5
Views: 769

Re: Array-related terminology: values vs. elements

Code: Select all

for Cat, Forum in ahk := {E: "E", A: "S", S: "", Y: "Y"}
    vote := Forum vote
MsgBox, 4096, Cat Forum, % vote
by Xtra
14 Nov 2019, 15:41
Forum: Ask For Help
Topic: Having odd issues with ToolTip Topic is solved
Replies: 22
Views: 1067

Re: Having odd issues with ToolTip Topic is solved

To clear a tooltip try changing:
ToolTip, , 0
to
ToolTip

To clear the first tooltip when you have multiple tooltips:
ToolTip,,,,1

Note: you can have 1-20 tooltips total
See: ToolTip

HTH

Go to advanced search