Search found 23 matches

by wiens
30 Sep 2019, 14:58
Forum: Ask For Help
Topic: Bug with <Alt> send commands
Replies: 3
Views: 438

Re: Bug with <Alt> send commands

Breaking the script in the middle and doing the <Alt> function mnanually works.
Send !J or Send !j both works without the two lines in it.

The issue is not only with AHK, but also with VBA.
by wiens
30 Sep 2019, 10:05
Forum: Ask For Help
Topic: Bug with <Alt> send commands
Replies: 3
Views: 438

Re: Bug with <Alt> send commands

There is a topic on this in the AutoCAD forum: https://forums.autodesk.com/t5/autocad-forum/keyboard-shortcuts-alt/td-p/2139188 It looks like it is by design in AutoCAD. Removing the two lines given below from the script and using <Alt> functions, it will work then in the whole script. acad := ComOb...
by wiens
27 Sep 2019, 09:51
Forum: General Discussion
Topic: Virus detected when compiling from v1.1.30.00
Replies: 14
Views: 4980

Re: Virus detected when compiling from v1.1.30.00

Thank you SOTE for this page: https://www.autohotkey.com/boards/viewtopic.php?f=17&t=62266 The AV-companies are bad nowadays. They block everything for security reasons, without checking it thoroughly. I agree with you. They should get banned for the false-positive heuristic scanning or get bad publ...
by wiens
27 Sep 2019, 04:24
Forum: Ask For Help
Topic: Bug in Regwrite in HKEY_LOCAL_MACHINE
Replies: 12
Views: 1355

Re: Bug in Regwrite in HKEY_LOCAL_MACHINE

gwarble, it didn't work with that workaround for me.
by wiens
27 Sep 2019, 04:15
Forum: Ask For Help
Topic: Bug with <Alt> send commands
Replies: 3
Views: 438

Bug with <Alt> send commands

Hello, There is a bug in AHK in combination with AutoCAD. All <Alt> send commands are blocked after using the the command acad.ActiveDocument.SendCommand The script stops at the <Alt> send command. Can you confirm this. Here is to AHK code to test on: ------------------------------------------------...
by wiens
13 Mar 2019, 23:13
Forum: Ask For Help
Topic: Bug in Regwrite in HKEY_LOCAL_MACHINE
Replies: 12
Views: 1355

Re: Bug in Regwrite in HKEY_LOCAL_MACHINE

What is causing this error if it is not in admin rights?
by wiens
08 Mar 2019, 08:26
Forum: Ask For Help
Topic: Bug in Regwrite in HKEY_LOCAL_MACHINE
Replies: 12
Views: 1355

Re: Bug in Regwrite in HKEY_LOCAL_MACHINE

The values are:
ErrorLevel = 1
A_LastError = 5
by wiens
08 Mar 2019, 04:27
Forum: Ask For Help
Topic: Bug in Regwrite in HKEY_LOCAL_MACHINE
Replies: 12
Views: 1355

Bug in Regwrite in HKEY_LOCAL_MACHINE

Hello, When you write registry key it will not work in HKEY_LOCAL_MACHINE: RegWrite, REG_SZ, HKEY_LOCAL_MACHINE\SOFTWARE\TestKey, MyValueName, Test Value When you write registry it works fine in HKEY_CURRENT_USER: RegWrite, REG_SZ, HKEY_CURRENT_USER\SOFTWARE\TestKey, MyValueName, Test Value So the b...
by wiens
22 Nov 2018, 07:27
Forum: General Discussion
Topic: Virus detected when compiling from v1.1.30.00
Replies: 14
Views: 4980

Re: Virus detected when compiling from v1.1.30.00

If you are working on a 64-bit machine change the base bin file in the compiler to 64-bit. This can fix the problem of yours.
by wiens
11 Nov 2018, 04:24
Forum: Ask For Help
Topic: ControlSend Topic is solved
Replies: 2
Views: 562

Re: ControlSend Topic is solved

In the Control Panel Telnet should be installed as additional software to Windows.

To let the script work in the 64-bit of Windows with option 2 you have to compile the AHK script with base .bin file: Unicode 64-bit.
by wiens
11 Nov 2018, 02:13
Forum: Bug Reports
Topic: Two Ahk2Exe.exe files in the installer of version 1.1.30. Topic is solved
Replies: 1
Views: 803

Two Ahk2Exe.exe files in the installer of version 1.1.30. Topic is solved

Hello,

There are two Ahk2Exe.exe files in the installer of version 1.1.30.01.
One of them is version 1.1.30.00 and one is 1.1.30.01. The version of 1.1.30.01 which is not located in the correct folder.
by wiens
07 Oct 2018, 02:48
Forum: General Discussion
Topic: Virus detected when compiling from v1.1.30.00
Replies: 14
Views: 4980

Re: Virus detected when compiling from v1.1.30.00

It has been fixed in the latest definitions of Windows Defender in Windows 10. There is no virus detection at this moment.
You can compile from version 1.1.30.00.
by wiens
01 Oct 2018, 18:43
Forum: General Discussion
Topic: Virus detected when compiling from v1.1.30.00
Replies: 14
Views: 4980

Re: Virus detected when compiling from v1.1.30.00

I have also the massive delay (caused by Windows Defender) during compiling in 1.1.30.00. So I switched back to 1.1.29.01.
by wiens
29 Sep 2018, 11:45
Forum: General Discussion
Topic: Virus detected when compiling from v1.1.30.00
Replies: 14
Views: 4980

Re: Virus detected when compiling from v1.1.30.00

It happens during the compiling of the (Default) base bin file.

This is the false-positive virus name:
Program:Win32/Unwaders.C!ml

I have submitted the compiler of AHK and the script file to Microsoft, so they can compile and see if it is a false-positive.
by wiens
29 Sep 2018, 02:44
Forum: General Discussion
Topic: Virus detected when compiling from v1.1.30.00
Replies: 14
Views: 4980

Virus detected when compiling from v1.1.30.00

[Moderator's note: Topic moved from Bug Reports.] There is a bug during compiling from version v1.1.30.00 Compiling a large .ahk files with Ahk2Exe.exe is blocked by Windows Defender in Windows 10. The Default compiling with base bin file (.bin): '(Default)' or 'v1.1.30.0 Unicode 32bit' gives a vir...
by wiens
10 Jan 2018, 22:21
Forum: Ask For Help
Topic: ControlSend Topic is solved
Replies: 2
Views: 562

Re: ControlSend Topic is solved

Option 1 ahk source code: ; On a 64-bit Operating System telnet.exe is used from '%windir%\WinSXS' subdirectory and not from the '%windir%\System32' subdirectory due to the default environment settings. ; To solve the problem select in the AHK compiler the 64-bit option from the list to compile the...
by wiens
15 Feb 2016, 09:04
Forum: Ask For Help
Topic: Error 0x800A9C64
Replies: 3
Views: 782

Re: Error 0x800A9C64

This error did occur because the user32 library was not declared in Word VBA. Private Declare Function OpenClipboard Lib "user32" (ByVal hwnd As Long) As Long Private Declare Function EmptyClipboard Lib "user32" () As Long Private Declare Function CloseClipboard Lib "user32" () As Long It is working...
by wiens
04 Feb 2016, 04:18
Forum: Ask For Help
Topic: Error 0x800A9C64
Replies: 3
Views: 782

Re: Error 0x800A9C64

i have found that link also, but it isn't solving the error.

I have also used "winword.exe /R" for restoring the default settings in the register and re-registering of the Word DLL's.
by wiens
03 Feb 2016, 14:35
Forum: Ask For Help
Topic: Error 0x800A9C64
Replies: 3
Views: 782

Error 0x800A9C64

On some machines I do get the error 0x800A9C64 when running the AHK script, see screenshot below: AHK.png Does anyone knows what the problem is? Somehow oWord.ActiveDocument.SaveAS(path) is not working. It won't save the Word file. Do I have to register (with regsvr32.exe) a system or Word DLL or so...
by wiens
08 Dec 2015, 17:58
Forum: Ask For Help
Topic: [SOLVED] Bug in Active Window Info version 1.1.22.09
Replies: 8
Views: 1328

Re: Bug in Active Window Info version 1.1.22.09

I know the error now. I did use:
PixelGetColor, OutputVar, X, Y
So it got swapped.

It should be like this:
PixelGetColor, OutputVar, X, Y, RGB

Topic can be closed. This is not a bug.

Go to advanced search