Search found 73 matches

by MonuKashyap
18 Aug 2020, 09:02
Forum: Ask For Help
Topic: Regexreplace fails to repalce "|" pipe
Replies: 1
Views: 44

Regexreplace fails to repalce "|" pipe

Code: Select all

newvar=1||2|3|4
var=|2
newvar := RegExReplace(newvar, var) ;;works incorrect
msgbox % newvar
in the above code the command Regexreplace successfully replaces 2, but failed to replace this pipe "|"
as shown in screenshot.

Regards,
An Ahk User
by MonuKashyap
09 Aug 2020, 01:16
Forum: Ask For Help
Topic: Automate chrome with ahk
Replies: 1
Views: 932

Automate chrome with ahk

Hello everyone!
I have searched many of wabpages about dealing with chrome with ahk, but nothing have found anything usefull,. can someone have a good tutorial or link about to automate chrome with ahk
and :happybday: to you in advance..
by MonuKashyap
28 Jul 2020, 07:50
Forum: Ask For Help
Topic: Newbie help
Replies: 12
Views: 2487

Re: Newbie help

try this :

!q::
send ^c
run %path_of_translator%
Return

;;Press Alt+q to start..
by MonuKashyap
28 Jul 2020, 07:43
Forum: Ask For Help
Topic: Winwait not working with COM/DOM
Replies: 1
Views: 677

Re: Winwait not working with COM/DOM

well, winwait works for secondtime :clap:
but not at first :roll:
by MonuKashyap
28 Jul 2020, 05:40
Forum: Ask For Help
Topic: Multicolor text in single listview?
Replies: 3
Views: 498

Re: Multicolor text in single listview?

LIKE THIS.png
LIKE THIS
LIKE THIS.png (2.09 KiB) Viewed 337 times
BNOLI wrote:
04 Jun 2020, 06:01
Would you specify 'multicolor'? Color faded? Different characters colored differently?? ...
by MonuKashyap
28 Jul 2020, 05:23
Forum: Ask For Help
Topic: sending string to another exe Topic is solved
Replies: 3
Views: 576

Re: sending string to another exe Topic is solved

Both Are Pefect !!

Thank You Guys...
by MonuKashyap
28 Jul 2020, 04:47
Forum: Ask For Help
Topic: Winwait not working with COM/DOM
Replies: 1
Views: 677

Winwait not working with COM/DOM

The "Winwait" command of autohotkey is not working with COM/DOM with this code : wb:=ComObjCreate("InternetExplorer.Application") wb.visible:=True wb.Navigate("www.anysite.com") while wb.busy sleep 100 wb.document.getElementById("MyId").contentWindow.document.getElementsByTagName("input")[2].click()...
by MonuKashyap
04 Jun 2020, 00:12
Forum: Ask For Help
Topic: Multicolor text in single listview?
Replies: 3
Views: 498

Multicolor text in single listview?

Is this possible to use multicolor text in single listview...??
any suggestion please...
by MonuKashyap
26 May 2020, 23:50
Forum: Ask For Help
Topic: 1 pc 2 user (with 2 monitor at same time)
Replies: 3
Views: 181

Re: 1 pc 2 user (with 2 monitor at same time)

Hy Banoli,
Thanks for the reply,,

one problem after that, I have no idea to getting and dealing with HID, any way, any link, any suggestion to go further pls..?
by MonuKashyap
24 May 2020, 21:43
Forum: Ask For Help
Topic: 1 pc 2 user (with 2 monitor at same time)
Replies: 3
Views: 181

1 pc 2 user (with 2 monitor at same time)

hotkey is not working when i am using single pc with 2 user (with 2 monitor simultaneously)

Numpad1::
Msgbox Numpad1 pressed!
Return

;This above script works on first user, but not for 2nd user.

any way to make this work for same pls..
by MonuKashyap
23 Apr 2020, 08:57
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

Re: missing some characters while sending

anyone please help for that.
text corrupted while sending text to Internet Explorer
(webpage is somekind of protected)

send, 123456789

sometimes, missed any digit.
by MonuKashyap
09 Apr 2020, 09:10
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

Re: missing some characters while sending

*Some day before it was fine, but one day i install a driver software for fingerprint device and then the problem starts happening*
to reverse that, i uninstalled the driver software, "but the problem still exist"
and i don't know, where and what is the problem..
and also how to solve this..
by MonuKashyap
09 Apr 2020, 05:02
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

Re: missing some characters while sending

Example , GUI with dropdownlist send to Chrome browser #SingleInstance, force SetTitleMatchMode, 2 SetKeyDelay,, 1 #IfWinExist,("ahk_class Chrome_WidgetWin_1 ahk_exe chrome.exe") sc=ahk_exe chrome.exe e5x= (Ltrim comments join| aaaa bbbb ) Gui,3: +AlwaysOnTop Gui,3:Add,DDL,x10 y10 w300 h200 cBlack ...
by MonuKashyap
09 Apr 2020, 03:46
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

Re: missing some characters while sending

maybe !h::Send {text}123456789 seems this work,,!! but i have another problem with that,, i have a dropdown list in internet explorer with contents like ... Other Type 1 Other Type 2 Other Type 3 is this condition when i use send ooo then sometimes it selects Other Type 2 and sometimes Other Type 3...
by MonuKashyap
09 Apr 2020, 03:07
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

Re: missing some characters while sending

Using Send is kinda mimicking a manual attempt, and as you see less reliable if interacting with IE's browser components. You need to go for more sophisticated methods/codes to be on the save side :) There are tons of sample code snippets at the forum. Unfortunately, your description of what you fi...
by MonuKashyap
09 Apr 2020, 03:05
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

Re: missing some characters while sending

okay,, ill try that..
and lot of thanks,, for reply for help
by MonuKashyap
08 Apr 2020, 09:21
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

Re: missing some characters while sending

Internet Explorer (ver 11.494)
by MonuKashyap
08 Apr 2020, 00:58
Forum: Ask For Help
Topic: missing some characters while sending
Replies: 12
Views: 703

missing some characters while sending

when I send some contents like send, 123456789 then sometimes it sends 12456789 ;(missed 3) sometimes sends 12346789 ;(missed 5) and sometimes somthing etc etc. and i am using clipboard for another use so i can't do like clipbard = 123456789 send % clipboard this problem happens in my second pc.. wh...
by MonuKashyap
14 Feb 2020, 06:32
Forum: Ask For Help
Topic: sending string to another exe Topic is solved
Replies: 3
Views: 576

sending string to another exe Topic is solved

How to send a string from "one.exe" to "another.exe" (both ahk compiled)

any idea pls??
:roll:

Go to advanced search