Search found 5 matches

by dcdc
10 Jul 2017, 04:30
Forum: AHK Studio
Topic: XML Class
Replies: 15
Views: 4064

Re: XML Class

You're great maestrith, it works well :) In order to loop through the DTMInfo nodes, and extract some name and version values, I do the following: mytext:="" IfExist, %DTMCatalog% { FileRead, xmlcontents, %DTMCatalog% NewXML:=New XML("xml") NewXML.XML.LoadXML(xmlcontents) NewXML.Language() list:=New...
by dcdc
07 Jul 2017, 10:29
Forum: AHK Studio
Topic: XML Class
Replies: 15
Views: 4064

Re: XML Class

Yes, great that worked! One step harder... I am blocked again on an error: in this case the attribute has a "d2p1" namespace, as follows: <?xml version="1.0" encoding="utf-8" standalone="yes"?> <DTMCatalogueFile xmlns="http://tempuri.org/XMLSchema.xsd"> <DTMCatalogue DTMCatalogue=""> <DTMCatalogData...
by dcdc
04 Jul 2017, 11:19
Forum: AHK Studio
Topic: XML Class
Replies: 15
Views: 4064

Re: XML Class

Hi, Great tool, thanks. Anyway I am very new to AH and a practical example would be providential. In example, I am trying to simply read one value from the following xml file, specifically the content of unity.ApplicationPath, that is "C:\Users\Public\Documents\Schneider Electric\Unity Pro" Could yo...
by dcdc
10 Feb 2017, 09:54
Forum: Ask For Help
Topic: Error on Runwait, %comspec% /c query session Topic is solved
Replies: 6
Views: 1353

Re: Error on Runwait, %comspec% /c query session Topic is solved

Sorry for the lack of information. I'll try to recover here.:) It should run on Windows 7 64bit Enterprise edition SP1. The screenshot comes from the execution of the whole application where the line is used, that prints the output into command prompt. Here's the full application Autologin.ahk Actua...
by dcdc
09 Feb 2017, 05:13
Forum: Ask For Help
Topic: Error on Runwait, %comspec% /c query session Topic is solved
Replies: 6
Views: 1353

Re: Error on Runwait, %comspec% /c query session Topic is solved

Using the code you proposed it still doesn't work, but it changes a bit the behavior. In fact, if I run the whole application I can see the output on command prompt. I get a "Invalid parameter(s)" message: https://s28.postimg.org/lvbt3fhxp/2017_02_09_10_26_14_C_Windows_system32_cmd.jpg At least it f...

Go to advanced search