Search found 1203 matches

by JoeWinograd
09 Mar 2019, 21:07
Forum: Ask For Help
Topic: Place alternative text under GUI buttons for use by screen readers
Replies: 6
Views: 289

Re: Place alternative text under GUI buttons for use by screen readers

> investigate GUIs with AccViewer

I've never tried AccViewer...I'll look into it.

> Oh great avatar btw.

Thanks! I'm very proud of that Fellow Award. But I still need to come here for help. :) Regards, Joe
by JoeWinograd
09 Mar 2019, 19:43
Forum: Ask For Help
Topic: Place alternative text under GUI buttons for use by screen readers
Replies: 6
Views: 289

Re: Place alternative text under GUI buttons for use by screen readers

Hi jeeswg,
Thanks for the ideas...much appreciated! Regards, Joe
by JoeWinograd
09 Mar 2019, 18:23
Forum: Ask For Help
Topic: Place alternative text under GUI buttons for use by screen readers
Replies: 6
Views: 289

Place alternative text under GUI buttons for use by screen readers

I'm working on a program that I want to be as good as possible for visually-impaired users. The program has several GUIs in it with buttons, all created via the AHK Gui,Add,Button statement. Is there a way to place so-called Alternative Text under the buttons such that the text is hidden, but that a...
by JoeWinograd
08 Mar 2019, 08:32
Forum: Ask For Help
Topic: GUI button loses default after coming back from any other window that gains focus
Replies: 3
Views: 210

Re: GUI button loses default after coming back from any other window that gains focus

Ah, Focus...works a charm! My thanks to both of you...perfect! And thanks for the link to the GuiControl, Focus thread...very interesting! Regards, Joe
by JoeWinograd
07 Mar 2019, 20:50
Forum: Ask For Help
Topic: GUI button loses default after coming back from any other window that gains focus
Replies: 3
Views: 210

GUI button loses default after coming back from any other window that gains focus

AHK 1.1.30.01 U32 W7 Pro 64-bit I don't know if this is a bug or not, but decided to post it here first before submitting a bug report. I have a script with three buttons. Any one of them can be marked as the Default when the user clicks on it (so that it is highlighted), while the other two are set...
by JoeWinograd
27 Feb 2019, 16:19
Forum: Ask For Help
Topic: Help for getting owner properties from a file on a server
Replies: 8
Views: 406

Re: Help for getting owner properties from a file on a server

> I had to modify it slightly to get the Current file var to show up. I don't understand that. The script works perfectly here. No reason to modify it that I can see. Don't know what you mean by "get the Current file var to show up". It shows up fine in the MsgBox dialog here. Anyway, what did you m...
by JoeWinograd
27 Feb 2019, 15:10
Forum: Ask For Help
Topic: Help for getting owner properties from a file on a server
Replies: 8
Views: 406

Re: Help for getting owner properties from a file on a server

Hi Shawn, Try this: AllPDFs:="\\192.168.168.1\plats\PDF DRAWINGS\*.PDF" Loop,%AllPDFs% { CurrentFile:=A_LoopFilePath oOwner:=ComObjGet("winmgmts:").ExecQuery("Associators Of {" "Win32_LogicalFileSecuritySetting='" CurrentFile "'} Where As" "socClass= Win32_LogicalFileOwner ResultRole=Owner") For itm...
by JoeWinograd
26 Feb 2019, 15:59
Forum: Ask For Help
Topic: Help for getting owner properties from a file on a server
Replies: 8
Views: 406

Re: Help for getting owner properties from a file on a server

Tested here with WS2012R2...works perfectly (with a full path in the CurrentFile variable). What server OS do you have?
by JoeWinograd
21 Feb 2019, 15:55
Forum: Ask For Help
Topic: Help for getting owner properties from a file on a server
Replies: 8
Views: 406

Re: Help for getting owner properties from a file on a server

Hi Shawn, I've used this code from TLM posted here : oOwner:=ComObjGet("winmgmts:").ExecQuery("Associators Of {" "Win32_LogicalFileSecuritySetting='" CurrentFile "'} Where As" "socClass= Win32_LogicalFileOwner ResultRole=Owner") For itm in oOwner Owner:=itm.ReferencedDomainName . "\" . itm.AccountNa...
by JoeWinograd
20 Feb 2019, 16:06
Forum: Scripts and Functions
Topic: [LIB] TrayIcon - Sean's TrayIcon for Unicode and 64 bit
Replies: 65
Views: 24709

Re: [LIB] TrayIcon - Sean's TrayIcon for Unicode and 64 bit

I just tried to edit this question with another "by the way" comment, but it got blocked by our new anti-spam methods. So, I'm trying to post it again via a new post instead of an edit of the first post (I think we're taking extra measures against edits because that's how our current spammer operate...
by JoeWinograd
20 Feb 2019, 15:57
Forum: Forum Issues
Topic: Recent spam, forum problems and some background information Topic is solved
Replies: 66
Views: 4042

Re: Recent spam, forum problems and some background information Topic is solved

I just tried to edit a question I posted and got blocked:

ahk forum blocked.gif
ahk forum blocked.gif (35.59 KiB) Viewed 662 times

How about a whitelist? Thanks, Joe
by JoeWinograd
20 Feb 2019, 15:14
Forum: Bug Reports
Topic: MouseMove to absolute coordinates not working
Replies: 3
Views: 582

Re: MouseMove to absolute coordinates not working

Ah, my bad! Thanks to both of you. It is, indeed, documented, and it is, indeed, a misunderstanding of Relative and Absolute on my part. Much appreciated, folks! Regards, Joe
by JoeWinograd
20 Feb 2019, 14:59
Forum: Forum Issues
Topic: Recent spam, forum problems and some background information Topic is solved
Replies: 66
Views: 4042

Re: Recent spam, forum problems and some background information Topic is solved

> You should definitely be allowed to use URLs.

Maybe it matters where the URLs go. Here's a screenshot, if it helps:
ahk forum links unable to post.gif
ahk forum links unable to post.gif (6.02 KiB) Viewed 696 times
Regards, Joe
by JoeWinograd
20 Feb 2019, 14:50
Forum: Bug Reports
Topic: MouseMove to absolute coordinates not working
Replies: 3
Views: 582

MouseMove to absolute coordinates not working

W7 Pro 64-bit AHK 1.1.30.01 U32 I'm running a source script (i.e., not compiled) by double-clicking the AHK file in my file manager (Total Commander). Here's the script: Sleep 2000 ; to make sure mouse hasn't moved after double-click MouseMove,100,100 Since I don't have Relative specified as the fou...
by JoeWinograd
20 Feb 2019, 09:51
Forum: Forum Issues
Topic: Recent spam, forum problems and some background information Topic is solved
Replies: 66
Views: 4042

Re: Recent spam, forum problems and some background information Topic is solved

Hi joedf, Our messages crossed. My original post had included the URLs of a library published here and its authors (Sean, Cyrus, and Fanatic Guru). Removing those URLs (some to this site, some elsewhere) allowed the post to go through. Of course, posting without URLs is a pain (I guess we could use ...
by JoeWinograd
20 Feb 2019, 09:43
Forum: Forum Issues
Topic: Recent spam, forum problems and some background information Topic is solved
Replies: 66
Views: 4042

Re: Recent spam, forum problems and some background information Topic is solved

Any tips on how I can post?
In answering my own question, removing the URLs allowed the post (keeping the BBCodes was fine). Regards, Joe
by JoeWinograd
20 Feb 2019, 09:41
Forum: Scripts and Functions
Topic: [LIB] TrayIcon - Sean's TrayIcon for Unicode and 64 bit
Replies: 65
Views: 24709

Re: [LIB] TrayIcon - Sean's TrayIcon for Unicode and 64 bit

First, I'd like to thank Sean, Cyruz, and FG for this superb library! It has been essential in the development of my latest program. I'm using the version with a Version Date of 2018-03-13 (my first attempt at this post included the library's URL, but that caused the post to be blocked by our new an...
by JoeWinograd
20 Feb 2019, 09:34
Forum: Forum Issues
Topic: Recent spam, forum problems and some background information Topic is solved
Replies: 66
Views: 4042

Re: Recent spam, forum problems and some background information Topic is solved

I am trying to post in a thread and keep getting blocked (with a Cloudflare Ray ID). I've tried the Quick Reply box and the Full Editor & Preview. Both are getting blocked. There are no attachments in my post...just some URLs and BBCodes in text copied/pasted from my text editor. Any tips on how I c...
by JoeWinograd
19 Feb 2019, 20:43
Forum: Forum Issues
Topic: Recent spam, forum problems and some background information Topic is solved
Replies: 66
Views: 4042

Re: Recent spam, forum problems and some background information Topic is solved

Thanks, gregster, I turned it off, although I guess it takes a while to kick in, as I've already received three quoted-you spam emails since turning it off.
by JoeWinograd
19 Feb 2019, 20:18
Forum: Forum Issues
Topic: Recent spam, forum problems and some background information Topic is solved
Replies: 66
Views: 4042

Re: Recent spam, forum problems and some background information Topic is solved

> It seems my settings prevent that I get e-mails when I get quoted - I see it only in the forum notifications.

Thanks, I'll look into that setting.

> this forum is accessible to people of all ages

Good point.

Go to advanced search