Search found 114 matches

by dsewq1LYJ
02 Sep 2015, 22:18
Forum: Bug Reports
Topic: [Fixed] Combinatin always give me wrong send letters.
Replies: 9
Views: 2298

Re: Combinatin always give me wrong send letters.

Is any colorscheme of AHK(lastest ver.) for Vim !? My vim does not support such follow new command(didn't highlighted). SetRegView Font Color Margin ...etc you can easily edit the vim colorscheme file to include those keywords if you are using the built-in syntax file that ships with Vim, then look...
by dsewq1LYJ
02 Sep 2015, 07:42
Forum: Scripts and Functions
Topic: CapsLock Status Tooltip
Replies: 5
Views: 1898

Re: CapsLock Status Tooltip

Code: Select all

if GetKeyState("CapsLock","T")
{
	SetCapsLockState,Off
	ToolTip,CapsLock is Off
	SetTimer,RemoveToolTip,432
}
else
{
	SetCapsLockState,On
	ToolTip,CapsLock is On
	SetTimer,RemoveToolTip,432
}
return

RemoveToolTip:
SetTimer,RemoveToolTip,Off
ToolTip
return
Not better but clear.
by dsewq1LYJ
02 Sep 2015, 02:55
Forum: Bug Reports
Topic: [Fixed] Combinatin always give me wrong send letters.
Replies: 9
Views: 2298

Re: Combinatin always give me wrong send letters.

I think there's some conflict between Send saving/restoring CapsLock and the custom combination hotkey trying to preserve CapsLock functionality. (CapsLocek and other modifier keys get special treatment for custom combinations, whereas normal keys which are used as custom modifiers are blocked by d...
by dsewq1LYJ
02 Sep 2015, 01:36
Forum: Bug Reports
Topic: [Fixed] Combinatin always give me wrong send letters.
Replies: 9
Views: 2298

Re: Combinatin always give me wrong send letters.

It seems you can work around it like this: CapsLock & p:: KeyWait CapsLock Send FOOBAR return But I need to release the CapsLock key to spawn "FOOBAR"? Is possible make it can trigger by "Press Down" event !? because I wanna rebind the "CapsLock & p" to navigate (Scroll down) my Application, and If...
by dsewq1LYJ
01 Sep 2015, 23:20
Forum: Bug Reports
Topic: [Fixed] Combinatin always give me wrong send letters.
Replies: 9
Views: 2298

[Fixed] Combinatin always give me wrong send letters.

e.g. #SingleInstance force CapsLock & p::Send,FOOBAR Q1. If your CapsLock is off. once you trigger the Hotkey it gives you "foobar"(lowercase) [btw --- CapsLock is on now] and AHK knows you are using the CapsLock combination, it revert the CapsLock back to the off and the second will spawn "FOOBAR" ...
by dsewq1LYJ
11 May 2015, 10:37
Forum: Ask For Help
Topic: Label or Hotkey cant not be same name !?
Replies: 2
Views: 649

Re: Label or Hotkey cant not be same name !?

Guest wrote:Hotkeys and hotstrings act as labels too - see http://ahkscript.org/docs/misc/Labels.h ... Hotstrings
Thank you for reply !
I am just confused about between hotkey and hotstring(label) :D

never mind ! I still can do same thing in another script !
by dsewq1LYJ
11 May 2015, 03:01
Forum: Ask For Help
Topic: Label or Hotkey cant not be same name !?
Replies: 2
Views: 649

Label or Hotkey cant not be same name !?

Code: Select all

#SingleInstance force

w::
w:
Exit
Duplicate label.
Specifically: w

Why !?
I know the "w:" is a label
but the "w::" should be a hotkey(Right!?)

Why the compiler tell me I got same label in script !?
:shock:
by dsewq1LYJ
10 May 2015, 22:16
Forum: SciTE4AutoHotkey
Topic: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]
Replies: 802
Views: 442166

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

lexikos wrote:For a start, you can try giving it the right path, by removing the part I highlighted in red. :roll:

Personally, I would just install the non-portable version.
Holy jesus.lexikos god :trollface:
:thumbup:

It work like a charm !
:crazy:

Thank you so much the GOD :D
by dsewq1LYJ
10 May 2015, 21:31
Forum: SciTE4AutoHotkey
Topic: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]
Replies: 802
Views: 442166

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

"C:\Program Files\AutoHotkey \.. " is not the AutoHotkey directory. It is the parent directory; i.e. Program Files. But how to tell the SciTE where my AHK is? I keep editing the AutoHotkeyDir of ahk.properties but it didnt work. Is me misunderstood somethin' !? My autohotkey is exactly in C:\Progra...
by dsewq1LYJ
10 May 2015, 21:13
Forum: SciTE4AutoHotkey
Topic: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]
Replies: 802
Views: 442166

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

joedf wrote:Always use quotes with paths that have spaces. ;)
AutoHotkeyDir=C:\"Program Files"\AutoHotkey\..
or
AutoHotkeyDir="C:\Program Files\AutoHotkey\.."

!?
by dsewq1LYJ
10 May 2015, 20:01
Forum: SciTE4AutoHotkey
Topic: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]
Replies: 802
Views: 442166

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

When it is set to 1, it means to use DirectX Rendering.. but It's currently sorta buggy, the default is GDI. Uh...there's another problem... I got path error after press F5. I know the scite can not get directory of AHK. So I edit the ahk.prop file by myself. AutoHotkeyDir=C:\Program Files\AutoHotk...
by dsewq1LYJ
10 May 2015, 10:09
Forum: SciTE4AutoHotkey
Topic: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]
Replies: 802
Views: 442166

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

joedf wrote:Yeah, theirs some weird-bugs some times in SciTE...
try setting technology=0
Wow

It works!
But what's the "technology" for !?
by dsewq1LYJ
07 May 2015, 20:01
Forum: SciTE4AutoHotkey
Topic: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]
Replies: 802
Views: 442166

Re: SciTE4AutoHotkey v3.0.06.01 [Updated October 12 2014]

Hello. I got some problem with my new NB. It seen to be wrong "redraw"(?) If I enter SciTEAHK it works great ! But after I navigate my caret times. Some weird situation appeared. http://i.imgur.com/kAh9JWy.png And another one. http://i.imgur.com/D7g8Jaf.png I did reinstall the SciTE and I try to fin...
by dsewq1LYJ
16 Apr 2015, 02:43
Forum: Ask For Help
Topic: StringSplit and use the array in a function.
Replies: 8
Views: 2010

StringSplit and use the array in a function.

Follow is the code: global aString aString=q|w|e|r|t StringSplit,aString,aString,| aFunc() return aFunc() { MsgBox,% aString MsgBox,%aString1% } I cant use "aString0" in my "aFunc". Why !? Because I didnt "split it as a global array"? Such as...(I can solve this problem by just adding follow code.Bu...

Go to advanced search