Search found 105 matches

by joshatt
09 Aug 2017, 05:09
Forum: Ask For Help
Topic: set value to Acc object children? Topic is solved
Replies: 13
Views: 4229

Re: set value to Acc object children? Topic is solved

Hi! Depending on the type of edit-control, accValue is most likely implemented as read-only. There's no "set_accValue" defined: https://msdn.microsoft.com/en-us/library/windows/desktop/dd318062%28v=vs.85%29.aspx You can (usually...) set the focus to the control by calling "accSelect" with the flag ...
by joshatt
08 Aug 2017, 21:41
Forum: Ask For Help
Topic: set value to Acc object children? Topic is solved
Replies: 13
Views: 4229

Re: set value to Acc object children? Topic is solved

Or, is it possible to focus on this text box object?
by joshatt
07 Aug 2017, 00:05
Forum: Ask For Help
Topic: set value to Acc object children? Topic is solved
Replies: 13
Views: 4229

set value to Acc object children? Topic is solved

Hi all, A text box in some window is my target. The following code pops up the correct message text, meaning Acc part is correct. #SingleInstance force #include Acc.ahk WinGet,hWnd,id, SOMETITLE window := Acc_ObjectFromWindow(hWnd) children := Acc_Children(window) MsgBox % children[11].accValue(0) B...
by joshatt
05 Aug 2017, 17:29
Forum: Ask For Help
Topic: what's wrong in my code?(clipboard)
Replies: 2
Views: 516

Re: what's wrong in my code?(clipboard)

If clipboard has a value before you use send,^c , then it is possible that the clipboard isn't updated in time on the system before ClipWait is executed, and sees any value (even the old value), and evaluates that as True, and moves onto the If statement which then processes with the old value. Wow...
by joshatt
05 Aug 2017, 05:25
Forum: Ask For Help
Topic: what's wrong in my code?(clipboard)
Replies: 2
Views: 516

what's wrong in my code?(clipboard)

Hi all, I have this script , it works for a while. Today I added some lines in the front to judge text encoding, but lower part of the script goes weird. Hopefully this picture ALONE can explain my question, thus no need to read the code. clipbd.jpg Anyway, my code: #Persistent #singleinstance,force...
by joshatt
25 Jun 2017, 06:40
Forum: Ask For Help
Topic: pass on filename as parameter?
Replies: 2
Views: 607

Re: pass on filename as parameter?

So you select some files (in explorer I assume), then want to send those to your compiled autohotkey script and the script passed them on to Photoshop? Selected files to script: See "Script Parameters" here https://autohotkey.com/docs/Scripts.htm#cmd so you can call your "script.exe file1 file2 etc...
by joshatt
21 Jun 2017, 03:43
Forum: Ask For Help
Topic: pass on filename as parameter?
Replies: 2
Views: 607

pass on filename as parameter?

Hi, I want to write a code, guessing it may be only 1 or 2 lines, but I just don't know how to do it. I want to compile it into an exe. There's a software, it has an function to run this exe while sending some photo file's filename(including path) to this exe, then this exe will pass the photo file ...
by joshatt
29 May 2017, 16:35
Forum: Ask For Help
Topic: my code switching chrome tabs,whats wrong?
Replies: 6
Views: 765

Re: my code switching chrome tabs,whats wrong?

I discarded #IF structure, and it works fine. Never know which and when window activated inside chrome during the procedure.
by joshatt
27 May 2017, 20:47
Forum: Ask For Help
Topic: my code switching chrome tabs,whats wrong?
Replies: 6
Views: 765

Re: my code switching chrome tabs,whats wrong?

Exaskryz wrote: (You wouldn't happen to have DetectHiddenWindows, On would you?)
No.
Coding about browser seems difficult, especially chrome has separate thread for each tab.
by joshatt
27 May 2017, 18:32
Forum: Ask For Help
Topic: my code switching chrome tabs,whats wrong?
Replies: 6
Views: 765

Re: my code switching chrome tabs,whats wrong?

Exaskryz wrote: use WinActivate ahk_exe chrome.exe (same to your #IfWinActive).
Tried ahk_exe, not working. But then I deleted WinActivate line, problem solved.
by joshatt
27 May 2017, 10:12
Forum: Ask For Help
Topic: my code switching chrome tabs,whats wrong?
Replies: 6
Views: 765

Re: my code switching chrome tabs,whats wrong?

I'm not too familiar with Chrome, but I do recall working with it that the ahk_class can be either Chrome_WidgetWin_1 or Chrome_WidgetWin_0. After you've checked the clipboard for the youtube.com, you ask to WinActivate the Chrome_WidgetWin_1 again. It may be that it changes classes in response to ...
by joshatt
27 May 2017, 08:38
Forum: Ask For Help
Topic: my code switching chrome tabs,whats wrong?
Replies: 6
Views: 765

my code switching chrome tabs,whats wrong?

Hi all, I'm writing a code to: with hotkey ctrl+Mbutton, first it will copy link, then switch between chrome tabs, when it finds a tab with title "transfer", it will do some click. The code is here: found:=0 #IfWinActive, ahk_class Chrome_WidgetWin_1 ^MButton:: Send, {RButton} ; ------these 3 lines ...
by joshatt
06 Oct 2016, 03:40
Forum: Ask For Help
Topic: function error or expression error?
Replies: 4
Views: 815

Re: function error or expression error?

Masonjar13 wrote:MouseMove's x and y parameters are already expressions, therefore, MouseMove, a-125, b+10 will suffice. What you were doing was dereferencing variables a and b, meaning to treat the contents of a and b as variables themselves.
Thanks for your instruction.
by joshatt
06 Oct 2016, 03:28
Forum: Ask For Help
Topic: function error or expression error?
Replies: 4
Views: 815

Re: function error or expression error?

kon wrote:Hi, try it like this:

Code: Select all

paste(FoundX, FoundY)
;...
MouseMove, % a-125, % b+10
- https://autohotkey.com/docs/Variables.htm#Expressions
- https://autohotkey.com/docs/Functions.htm#intro

Hope this helps :)
Oh, I see. Thanks for your help!
by joshatt
05 Oct 2016, 19:11
Forum: Ask For Help
Topic: function error or expression error?
Replies: 4
Views: 815

function error or expression error?

Hi, Could anybody please take a look at my code? it's very simple, just imagesearch then mousemove. Only the last step turned out wrong, but I don't know how. CoordMode, Pixel, Screen CoordMode, Mouse , Screen SetTitleMatchMode, 2 #Persistent return OnClipboardChange: IfWinNotExist, sometitle Return...
by joshatt
05 Oct 2016, 19:06
Forum: Ask For Help
Topic: soundget gives me 0.000000?
Replies: 6
Views: 1104

Re: soundget gives me 0.000000?

lexikos wrote:That would seem to indicate that your AutoHotkey version is outdated by a couple of years. SoundGet OutputVar in v1.1.10 and later should always return the same value as VA_GetMasterVolume().

Code: Select all

if (A_AhkVersion < "1.1.10")
    MsgBox Better update AutoHotkey!
I see. Thanks!
by joshatt
30 Sep 2016, 19:45
Forum: Ask For Help
Topic: soundget gives me 0.000000?
Replies: 6
Views: 1104

Re: soundget gives me 0.000000?

Capn Odin wrote:Assuming you have already tried running it with administrator privileges, I suggest trying VA_GetMasterVolume of Vista Audio Control Functions.

Code: Select all

#Include <VA>
MsgBox, % VA_GetMasterVolume()
VA works great.
Thank you so much !
by joshatt
30 Sep 2016, 08:44
Forum: Ask For Help
Topic: soundget gives me 0.000000?
Replies: 6
Views: 1104

Re: soundget gives me 0.000000?

Capn Odin wrote:Try running this.

Code: Select all

SoundGet, OutputVar
MsgBox, % ErrorLevel
The Meaning of the msgbox can be found here SoundGet ErrorLevel
Thank you for your help.
I get "0" with ErrorLevel, which means success. But the result "0.000000" is not right.
by joshatt
30 Sep 2016, 06:44
Forum: Ask For Help
Topic: soundget gives me 0.000000?
Replies: 6
Views: 1104

soundget gives me 0.000000?

Hi, I'm trying to control volume specificly within my TOSHIBA laptop(win7 x64), but just the first step I get error by simply testing "soundget" ------ With Soundget or Soundgetwavevolume, with "MASTER","SPEAKER" or empty paramater, I'll always get result: "0.000000". Could anybody please tell me wh...
by joshatt
30 Aug 2016, 03:19
Forum: SciTE4AutoHotkey
Topic: Improved auto-complete for SciTE
Replies: 14
Views: 14556

Re: Improved auto-complete for SciTE

But file has to be saved in order for any new variable be remembered. The list of words is retrieved by buildNames , which is only called when you save or open a file. The difference is that my script caches the list of words, whereas the one you posted recreates it (by scanning the entire file) ev...

Go to advanced search