Disabling/enabling menu bar item - BackgroundTrans

Report problems with documented functionality
m3user
Posts: 164
Joined: 17 Jan 2014, 18:11

Disabling/enabling menu bar item - BackgroundTrans

16 Dec 2019, 07:34

Enabling and disabling the main menu bar item affects the text with BackgroundTrans option - please see the example:

Code: Select all

Menu, FileMenu, Add, File1, Handler
Menu, MenuBar, Add, Menu, :FileMenu
Gui, Menu, MenuBar
Gui, Font, s12
Gui, Add, Text, w200 BackGroundTrans, Testing...
Gui, Show

loop 3
{
   sleep 1000
   Menu, MenuBar, Disable, Menu
   sleep 1000
   Menu, MenuBar, Enable, Menu
}
return

Handler:
return
joefiesta
Posts: 377
Joined: 24 Jan 2016, 13:54
Location: Pa., USA

Re: Disabling/enabling menu bar item - BackgroundTrans

16 Dec 2019, 11:17

thanks for supplying a working script. But, the text doesn't change in any way running it on Windows 7 pro, 32-bit. AHK version 1.1.30.01. Exactly how is your text affected?
User avatar
TheDewd
Posts: 1391
Joined: 19 Dec 2013, 11:16
Location: USA

Re: Disabling/enabling menu bar item - BackgroundTrans

16 Dec 2019, 12:18

I'm running Windows 10 Enterprise (64-bit) using AutoHotkey 1.1.32.00 (32-bit). I have the same issue when using your test script.

The text begins to show a pink-ish outline with each iteration of the loop, until the window is forced redrawn by moving the window off screen and then back on again.

The issue seems to be related to the redrawing.
Image Bulldozer - Sokoban inspired game from 1994 recreated in AutoHotkey.
User avatar
lmstearn
Posts: 331
Joined: 11 Aug 2016, 02:32
GitHub: lmstearn
Contact:

Re: Disabling/enabling menu bar item - BackgroundTrans

17 Dec 2019, 07:27

W10 Home 1.1.32.00 (32-bit) 1440 X 900.
Tried a bigger font: s20- not too much of a discernible difference in the quality of font, but the purplish tinge becomes apparent in the "in" of testing.
Tried s8, the font rendering gets blurry. Turning off cleartype, the colour at s20 has gone, but the "es" of testing gets blurry.
:arrow: itros "ylbbub eht tuO kaerB" a ni kcuts m'I pleH

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 10 guests