Winset fail since Windows Update

Report problems with documented functionality
contra3
Posts: 2
Joined: 19 Jun 2020, 22:49

Winset fail since Windows Update

19 Jun 2020, 23:42

Hi.
Winset, region fail since my pc getting the update Windows 10 2004 2020 june.
Hidden area will be change color gray or black instead of Transparent.
Also I experience showing a more deep bottom window, usually showing the window just below.
Window is not redrawn after WinMove command.
Mozilla Firefox 77.0.1 and notepad window was tried.
I didn't change my system except the Windows Update.
would you fix the problem please?
thank you, Autohotkey and mechanics :angel:
guest3456
Posts: 3123
Joined: 09 Oct 2013, 10:31

Re: Winset fail since Windows Update

20 Jun 2020, 13:51

can you post example code demonstrating the problem?

contra3
Posts: 2
Joined: 19 Jun 2020, 22:49

Re: Winset fail since Windows Update

22 Jun 2020, 01:43

Code I wrote:
WinGet, Firefox_id, ID, Firefox ahk_class MozillaWindowClass ahk_exe firefox.exe
WinSet, Region, H300 W600 10-10, ahk_id %Firefox_id%

and, moving window on dragging title bar gets error of redrawn.
I want to paste a screenshot, this effect is not reflected in capture, I don't know why it is. :crazy:
awk
Posts: 2
Joined: 23 Jun 2020, 01:27

Re: Winset fail since Windows Update

23 Jun 2020, 01:38

Same issues here.
"Winset, Region" + "winset style,"

Code: Select all

	WinMove, , ,1146, 168, 1486, 1028
	WinSet, Region, 218-0 W928 H968
	WinSet, Style, -0xC40000, A
Geforce GTX 750 Ti, the latest driver
User avatar
haichen
Posts: 487
Joined: 09 Feb 2014, 08:24

Re: Winset fail since Windows Update

23 Jun 2020, 03:53

Code: Select all

	WinGet, Firefox_id, ID, ahk_class MozillaWindowClass 
	WinSet, Region, H300 W600 10-10, ahk_id %Firefox_id%

Code: Select all

	WinActivate, tester.txt
	WinMove, A, ,1146, 168, 1486, 1028
	WinSet, Region, 218-0 W208 H200, A
	WinSet, Style, -0xC40000, A
This works. Have a look at WinTitle.
awk
Posts: 2
Joined: 23 Jun 2020, 01:27

Re: Winset fail since Windows Update

23 Jun 2020, 04:56

No. Doesn't work yet. Not the WinTitle problem, IMHO
1) AutoHotKey 1.1.32.00, Window 10, Version 2004, (OS build 19041.329)
- Win7 nicely work

2) Chrome/Firefox/Opera/Windows Edge/....
- 4+ type of browsers tested

3) GeForce GTX 750 Ti
- Driver Version: 446.14-desktop-win10-64bit-international-dch-whql, (the latest version)
- I really think the device driver is the most possible problem(s) that may occur for the issues above. I will retest if any new device available.

Here the full script

Code: Select all

^!6::
DetectHiddenWindows, on
if !WinExist("TweetDeck -")
{
	run, C:\Program Files (x86)\Google\Chrome\Application\chrome.exe --new-window https tweetdeck.twitter.com /  Broken Link for safety
}
else ifWinActive
{
	Send, !{esc}
	IfWinActive
	{
		WinActivate, ahk_class Shell_TrayWnd
	}
	WinMinimize
}
else 
{
	WinActivate
	WinWaitActive
	WinMove, , ,1008 ,711, 1008, 1518
	WinSet, Region, 82-86 W1003 H2000, A
	WinSet, Style, -0xC40000, A
}
DetectHiddenWindows, off
return


Last edited by awk on 23 Jun 2020, 11:01, edited 1 time in total.
User avatar
boiler
Posts: 5661
Joined: 21 Dec 2014, 02:44

Re: Winset fail since Windows Update

23 Jun 2020, 08:07

It’s interesting that the only people reporting the issue are using Windows 10 version 2004. I am using version 1909 even though it installed updates yesterday, and I’m not able to reproduce the problem. Version 2004 is the first version that includes “Graphics and display” updates since Windows 10 was released.

https://docs.microsoft.com/en-us/windows/whats-new/whats-new-windows-10-version-2004
User avatar
haichen
Posts: 487
Joined: 09 Feb 2014, 08:24

Re: Winset fail since Windows Update

23 Jun 2020, 08:26

My System:
Window 10, Version 2004, (OS build 19041.329)
GeForce GTX 960
- Driver Version: 446.14
Autohotkey 1.1.32.00

What about using quotes?:

Code: Select all

;...
run, "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --new-window https://tweetdeck.twitter.com 
;...
And so it looked:https://www.screenpresso.com/=CioIf

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 6 guests