Disable Alt+Enter in game

Ask gaming related questions
DemonicW
Posts: 1
Joined: 03 Oct 2019, 00:38

Disable Alt+Enter in game

03 Oct 2019, 00:45

So I'm new to AHK and from what I've read

#IfWinActive SwgClient

!Enter::return

should prevent Alt+enter from maximizing the game, right?
I've tried numerous scripts on google but none of them worked :headwall:

When alt+tabbing, for some reason this game will recognize it as alt+enter and it's driving me nuts.
Even without "#IfWinActive SwgClient" it still doesn't work.
nitrofenix
Posts: 18
Joined: 20 Sep 2019, 03:26

Re: Disable Alt+Enter in game

03 Oct 2019, 03:48

Have you tried using ahk_class or ahk_exe rather than matching the window by title? Could also try using a different SendMode?

Something like this (amend the exe name to suit, I took a guess at what it actually is -- also, I use braces with #IfWin from habit but I don't know if it makes a massive difference or not):

Code: Select all

SendMode Input

#IfWinActive ahk_exe swgclient_r.exe
{
	!Enter::return
}
gregster
Posts: 3389
Joined: 30 Sep 2013, 06:48

Re: Disable Alt+Enter in game

03 Oct 2019, 04:28

These directives are purely positional... so, braces are not helping here and rather misleading (instead you would close a context-sensitive section with #If or some #IfWin... directive, just without any parameter).

But if I understand the original poster correctly, (s)he uses alt+tab when this happens and not alt+enter at all (the game just behaves as if).
So that hotkey is probably not gonna help, even if it's de-activates !Enter. Not sure what would, though... 🤷‍♂️ perhaps ask the game developers to fix it :shifty:

Return to “Gaming”

Who is online

Users browsing this forum: No registered users and 55 guests