Page 1 of 1

GTA

Posted: 06 Jan 2020, 11:06
by Gyro-Gearloose
I am an absolute beginner and am trying to send keystrokes to GTA. I can send any short text to the chat dialogue like "catchup is for kids", but canĀ“t envoke the chat dialog (sending just "T"). That would be my first step in AHK. I got a feeling that taking this first hurdle would be the initial ignition.

Re: GTA

Posted: 13 Jan 2020, 07:24
by SyntaxTerror
Hello @Gyro-Gearloose

This script opens the main chat input box when you press Ctrl + T (code: ^t, you can use something else if you want) and types your text:

Code: Select all

^t::
Send, t
Sleep 200
Send, catchup is for kids
Return
(tested on GTA Online)

You can add {Enter} after kids so it sends the message immediately, but I wouldn't advise that as AutoHotKey sometimes makes unexpected things with GTA5, so like that you can review the text before sending it in the main chat.

You can also add #IfWinActive ahk_class grcWindow at the beggining and #IfWinActive at the end to make it work only when GTA5 window is active.

Good luck.

[EDIT] please don't post your questions twice (cf. https://www.autohotkey.com/boards/viewtopic.php?f=9&t=71538&p=309243#p309243 ), even if it is in different languages, especially if you forget to say that the question in solved in the second one...

Re: GTA  Topic is solved

Posted: 13 Jan 2020, 12:23
by gregster
Posting a question in two different languages is usually not a problem (after all, the german request came after this one was unanswered for 6 days).
But yes, a short update (possibly with a link to the solution) would be nice, if the problem is solved in one of the two threads.

Re: GTA

Posted: 21 Apr 2020, 01:04
by Gyro-Gearloose
Thank you @SyntaxTerror, thank you very much indeed. I didn't manage so far to get notifications or i did not notice. So forgive me for my late reply. Passing "t" to GTA works. That is I can evoke the chat-dialogue. But the dialogue stays empty. Not text occurs. What am I doing wrong?
send, t
Sleep 200
Send, catchup is for kids
return

Re: GTA

Posted: 21 Apr 2020, 03:13
by Gyro-Gearloose
Oh, no. You have fooled yourself and me. GTA does not care whether you press t or ctrl+t. Try assigning the command send t to any other key but t and see what happens.