Page 1 of 1

Disable mousewheel for Rage2

Posted: 15 May 2019, 16:36
by no1uno
In games I use the trackball scroll wheel button to move forward (missing middle finger on left hand, can't use the default W) -- most games, including Rage2, use the scroll wheel to cycle weapons, and don't allow changing that. I can usually deal with it, but Rage2 seems especially sensitive, so I'm constantly changing weapons while moving forward. (And I can't find any Rage2 config file to tweak.)

Tried this:

#IfWinActive, RAGE2.exe
WheelDown::
Return
WheelUp::
Return
#If

Does not work, and I've done lots of searching -- help please?

Re: Disable mousewheel for Rage2

Posted: 15 May 2019, 17:57
by Xtra
Try:
#IfWinActive, ahk_exe RAGE2.exe

Re: Disable mousewheel for Rage2

Posted: 16 May 2019, 12:16
by no1uno
Thanks, but no change.

#IfWinActive, ahk_exe RAGE2.exe
WheelDown::
Return
WheelUp::
Return
#If

Re: Disable mousewheel for Rage2

Posted: 18 May 2019, 14:40
by no1uno
Anyone have a link to a script that generally disables the mousewheel? (FYI Logitech Options' sole option for the wheel is reversing direction.)

Re: Disable mousewheel for Rage2

Posted: 20 May 2019, 10:44
by no1uno
Never mind -- this does disable the wheel:
WheelDown::
Return
WheelUp::
Return

Generally, but not in Rage2, so I gather I need to look for a Rage2-specific non-ahk fix, dangit.

Re: Disable mousewheel for Rage2

Posted: 20 May 2019, 10:55
by Xtra
Make sure the .exe name is correct you can also try the window class or window title.

Re: Disable mousewheel for Rage2

Posted: 20 May 2019, 12:08
by no1uno
Xtra wrote:
20 May 2019, 10:55
Make sure the .exe name is correct you can also try the window class or window title.
Windows' Task Manager shows the game as RAGE2.exe, which is how I have it. I tried adding the launcher too:
#IfWinActive, ahk_exe BethesdaNetLauncher.exe RAGE2.exe
Still no effect.
The game runs fullscreen, so I'm not sure whether/how it would work to "try the window class or window title" -- it CAN run in a window, how would I do this in ahk?

Thanks!

Re: Disable mousewheel for Rage2

Posted: 20 May 2019, 14:29
by Xtra
Use Active Window Info (window spy) that comes with ahk.

Re: Disable mousewheel for Rage2

Posted: 20 May 2019, 16:08
by no1uno
Thanks -- got the below from Window Spy, tried
#IfWinActive, ahk_class RAGE2
WheelDown::
Return
WheelUp::
Return
#If

Still did not work. Tho since turning off the mousewheel all the time (with ahk) works in Windows but not Rage2, I suspect the Rage2 folk have done something deep indeed....

>>>>>>>>>>( Window Title & Class )<<<<<<<<<<<
RAGE2
ahk_class RAGE2

>>>>>>>>>>>>( Mouse Position )<<<<<<<<<<<<<
On Screen: 700, 537 (less often used)
In Active Window: 700, 537

>>>>>>>>>( Now Under Mouse Cursor )<<<<<<<<

Color: 0xF0F0F0 (Blue=F0 Green=F0 Red=F0)

>>>>>>>>>>( Active Window Position )<<<<<<<<<<
left: 0 top: 0 width: 3440 height: 1440

>>>>>>>>>>>( Status Bar Text )<<<<<<<<<<

>>>>>>>>>>>( Visible Window Text )<<<<<<<<<<<

>>>>>>>>>>>( Hidden Window Text )<<<<<<<<<<<

>>>>( TitleMatchMode=slow Visible Text )<<<<

>>>>( TitleMatchMode=slow Hidden Text )<<<<

Re: Disable mousewheel for Rage2

Posted: 20 May 2019, 16:18
by gregster
Try to run your script as admin... and use borderless windowed mode (or similar) instead of fullscreen.
Perhaps this helps, too: https://www.autohotkey.com/boards/viewtopic.php?t=11084

Re: Disable mousewheel for Rage2

Posted: 28 May 2019, 11:53
by no1uno
Thanks, but none of those things worked (except I didn't try 2nd user or Expert steps). Thanks tho!

Re: Disable mousewheel for Rage2

Posted: 05 May 2020, 15:39
by chaoscreater
I had the same issue. I just had to do this and it works:

WheelUp::WhellDown
WheelDown::WheelUp

Essentially you just cancel the action with an opposite action.