AHK Tutorial No Longer Working

Discuss issues and requests related with the forum software
Posts: 37
Joined: 16 Aug 2017, 12:37

AHK Tutorial No Longer Working

26 Feb 2018, 08:59

Tutorial Screen.pdf
(28.18 KiB) Downloaded 57 times
Recently https://autohotkey.com/docs/frame.htm#Tutorial.htm stopped working correctly.
I am using W10x64, Latest Firefox (tried new install), latest AHK (reinstalled)
Page loads the same in Firefox & Chrome, see pdf for window screen shot, but none of the buttons work, nothing is displayed in the index window or the main window and the text above the index search window is garbled.

Temporarily I started using https://lexikos.github.io/v2/docs/Tutorial.htm which works fine but it is missing several commands so I would like to get the tutorial from AHK working again.
User avatar
Posts: 1127
Joined: 29 Sep 2013, 17:15
Location: USA

Re: AHK Tutorial No Longer Working

26 Feb 2018, 12:46

It works for me.
However, I have a browser addon that makes all pages dark (well, tries to. it's okayish). and maybe a week+ ago it no longer makes the whole docs page dark, only the sidebar, not the page content itself. So something most likely did change.

also, don't make screenshots as pdf >_> that's the first time I've seen someone do that.
just save the screen (printscreen) or window (alt+printscreen) as png or jpg, use a site like imgur (you can copy/paste onto that site, no file needed) or even the forum attachment. we won't need to download anything to see it.
rawr. fear me.
Is it December 21, 2012 yet?
Posts: 2501
Joined: 30 Sep 2013, 06:48

Re: AHK Tutorial No Longer Working

26 Feb 2018, 13:12

Try purging the cache of your browser - Ragnar said it had to with Cloudflare?! But since the last server maintenance a few days ago, the [docs] tag in posts and the docs links in code boxes are broken: sleep --> error message
Posts: 37
Joined: 16 Aug 2017, 12:37

Re: AHK Tutorial No Longer Working

27 Feb 2018, 04:25

Thank you for the suggestions. Unfortunately I tried removing add-ons and purging the cache before posting.
The problem appears to be fixed after I did the following...
Searched "ahk tutorial" in google, right clicked "beginners tutorial", selected "open in private window" in Firefox, the tutorial came up correctly and from then on it has worked correctly regardless of how I open it. I did this shortly after posting the problem, and I have no way to recreate the problem now so I have no idea if the above actually solved the problem.
If you have a similar problem try the above.
User avatar
Posts: 7075
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada

Re: AHK Tutorial No Longer Working

08 Mar 2018, 21:43

ahaha pdf ;]
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500 @ 3.00 GHz, 16GB DDR4 2133 MHz, NVIDIA GTX 1060 6GB | [About Me] | [ASPDM - StdLib Distribution]
[Populate the AHK MiniCity!] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library] | [About the AHK Foundation]

Return to “Forum Issues”

Who is online

Users browsing this forum: No registered users and 9 guests