fix this!!!

Discuss issues and requests related with the forum software
User avatar
tank
Posts: 2855
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Irving TX
Contact:

Re: fix this!!!

06 Feb 2019, 18:46

swagfag wrote:
06 Feb 2019, 17:57
fix this!!!
tsk tsk such demands .I looked up your IP from this post and it is not blocked. I cant look at the firewall without the IP that is blocked. Given that i have been actively banning IP with SQL injection code today, once i receive your banned IP from you i will look at logs before i decide what to do.
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
Check Out WebWriter
Thanks Tank :thumbup:
swagfag
Posts: 4126
Joined: 11 Jan 2017, 17:59

Re: fix this!!!

07 Feb 2019, 02:49

https://www.autohotkey.com/boards/viewtopic.php?p=262378#p262378
(I keep getting blocked by the site when I try to post the full script with GDIP included like in the post above...).
the GDIP lib or plain(certain?) DllCalls seem to be the culprit
swagfag
Posts: 4126
Joined: 11 Jan 2017, 17:59

Re: fix this!!!

07 Feb 2019, 04:04

thats not it. its SubStr_() (underscore here cuz otherwise i cant post it) that triggers it. which means something got borked between yesterday and the day before, since my earlier reply in that thread already included a call to SubStr and it could be posted just fine
User avatar
tank
Posts: 2855
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Irving TX
Contact:

Re: fix this!!!

07 Feb 2019, 07:12

Thanks for the additional insight. This is helpful for me to know which rules are too aggressively set
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
Check Out WebWriter
Thanks Tank :thumbup:
User avatar
tank
Posts: 2855
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Irving TX
Contact:

Re: fix this!!!

07 Feb 2019, 07:22

Code: Select all

chr_(0x23)
Substr_(var,1,2)
ok check now guys
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
Check Out WebWriter
Thanks Tank :thumbup:
swagfag
Posts: 4126
Joined: 11 Jan 2017, 17:59

Re: fix this!!!

07 Feb 2019, 07:40

it still says blocked for now, but maybe it takes a while for the changes to propagate
User avatar
tank
Posts: 2855
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Irving TX
Contact:

Re: fix this!!!

07 Feb 2019, 10:15

No i didnt target the right rule. Nikkk worked with me and we identified the specific rule and turned it off
Please try again
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
Check Out WebWriter
Thanks Tank :thumbup:
swagfag
Posts: 4126
Joined: 11 Jan 2017, 17:59

Re: fix this!!!

07 Feb 2019, 10:22

Code: Select all

chr(0x23)
Substr(var,1,2)
works, for these 2 that im aware of, at least
Spoiler
User avatar
joedf
Posts: 7888
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada
Contact:

Re: fix this!!!

07 Feb 2019, 10:23

:lol:
User avatar
nnnik
Posts: 4480
Joined: 30 Sep 2013, 01:01
Location: Germany

Re: fix this!!!

07 Feb 2019, 10:24

Nikkk
:(
Recommends AHK Studio
User avatar
joedf
Posts: 7888
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada
Contact:

Re: fix this!!!

07 Feb 2019, 10:25

hooo nooooesss :(
User avatar
tank
Posts: 2855
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Irving TX
Contact:

Re: fix this!!!

07 Feb 2019, 10:54

swagfag wrote:
07 Feb 2019, 10:22
Spoiler
Done
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
Check Out WebWriter
Thanks Tank :thumbup:
swagfag
Posts: 4126
Joined: 11 Jan 2017, 17:59

Re: fix this!!!

07 Feb 2019, 11:21

excellent. thank you
RickC
Posts: 253
Joined: 27 Oct 2013, 08:32

Re: fix this!!!

07 Feb 2019, 11:32

I'm also getting the same Cloudflare Captcha as in the first post. Fine, I confirmed I'm not a robot... so why does it re-appear when I'm navigating the site? So annoying...
User avatar
tank
Posts: 2855
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Irving TX
Contact:

Re: fix this!!!

07 Feb 2019, 12:07

There will be some additional captcha requests. this is unavoidable result of bad actors attacking this site. Please PM me the IP you were using when you got it
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
Check Out WebWriter
Thanks Tank :thumbup:
sinbad
Posts: 40
Joined: 01 Mar 2018, 09:32

Re: fix this!!!

07 Feb 2019, 12:18

I am also getting this error now whichever computer I use and I have tried with a VPN and it was still the same.
ahketype
Posts: 94
Joined: 27 Oct 2016, 15:06

Re: fix this!!!

08 Feb 2019, 07:27

I'm getting the same issue of having to prove I'm not a robot if I don't navigate for several minutes, although it's not telling me I'm banned. In my case, I don't think it's anything to do with the scripts I'm posting, because I'm just navigating - maybe we're dealing with two different issues here.

Anyway, it would be great if you can fix this, because if I am posting a reply or something and don't copy the text first (or if I go from Quick Reply to Full Editor & Preview or refresh the Preview), I lose all the text when I get through the thing! Someone could write a lot and lose it all. I've checked "Remember me" in logging in, btw. I'm not inclined to get the Firefox security pass account or whatever it suggests is another way to avoid this.

Here we go - Ctrl-A, Ctrl-C, Submit... No, I'm not a robot ... Ctrl-V, Submit ... ;)
swagfag
Posts: 4126
Joined: 11 Jan 2017, 17:59

Re: fix this!!!

08 Feb 2019, 07:40

i think if u do Browser_Back a bunch of times when that happens, the text that uve written should reappear
not entirely lost, but risky nonetheless
User avatar
tank
Posts: 2855
Joined: 28 Sep 2013, 22:15
Facebook: charlie.simmons.7334
Google: ttnnkkrr
GitHub: ttnnkkrr
Location: Irving TX
Contact:

Re: fix this!!!

08 Feb 2019, 11:09

ahketype wrote:
08 Feb 2019, 07:27
....dealing with two different issues here
Yep
ahketype wrote:
08 Feb 2019, 07:27
posting a reply or something and don't copy the text first (or if I go from Quick Reply to Full Editor & Preview or refresh the Preview), I lose all the text when I get through the thing!
That shouldn't loose the POST data...
ahketype wrote:
08 Feb 2019, 07:27
if I don't navigate for several minutes
the firewall then sees you as a new visitor.

Let me investigate the loosing POST data a little bit but let me post here why the UK and a few other countries are getting more captchas. The amount of malicious traffic originating from these countries is triggering the firewall to challenge all visitors from those origins. Its based i think on some kind of ratio of good vs bad traffic.
We are troubled on every side‚ yet not distressed; we are perplexed‚
but not in despair; Persecuted‚ but not forsaken; cast down‚ but not destroyed;
https://www.facebook.com/ahkscript.org
If you have forum suggestions please submit a pull request
Check Out WebWriter
Thanks Tank :thumbup:

Return to “Forum Issues”

Who is online

Users browsing this forum: No registered users and 2 guests