✅ [a105] CHM Search tab performance degradation Topic is solved

Discuss the future of the AutoHotkey language
User avatar
lvalkov
Posts: 39
Joined: 08 Mar 2019, 16:39

✅ [a105] CHM Search tab performance degradation

27 Sep 2019, 17:53

This issue has been resolved as of:

Having just recently updated to a105, I observe a slight, albeit rather annoying, performance regression when accessing most items in the Search tab.
The other tabs aren't affected. Previous versions might be, however, I haven't experimented any further to ascertain that. The a100 CHM does not exhibit this issue.

Below I am attempting to open pages as fast as the help viewer would permit. Note the unaffected items.
Image
Last edited by lvalkov on 08 Dec 2019, 09:56, edited 1 time in total.
User avatar
Ragnar
Posts: 266
Joined: 30 Sep 2013, 15:25

Re: [a105] CHM Search tab performance degradation  Topic is solved

30 Sep 2019, 16:05

This will be fixed. The cause for this is that each time something is changed in the Edit control, a new Click event handler is added to the ListBox control, but older ones are not removed. This forces each item in the ListBox to handle the same event multiple times, causing performance issues. For now, you can work around this issue by reloading the page (e.g. by pressing F5).
User avatar
lvalkov
Posts: 39
Joined: 08 Mar 2019, 16:39

Re: [a105] CHM Search tab performance degradation

07 Dec 2019, 18:49

The issues seem to have been resolved. Thank you.

Return to “AutoHotkey v2 Development”

Who is online

Users browsing this forum: No registered users and 18 guests