adding tf.ahk library result in utf error

Get help with using AutoHotkey and its commands and hotkeys
Ziad El Hachem
Posts: 21
Joined: 29 Aug 2016, 08:19

adding tf.ahk library result in utf error

16 Nov 2016, 13:36

Dear all

whenever adding tf.ahk library, with include or no (both methods),
i get the following:

Error at line 1 in #include file "C:\Program Files\Autohokey\lib\TF.ahk"

Line Text:'utf
Error: The leftmost character above is illegal in an expression.


Any help?
mandus
Posts: 12
Joined: 27 Oct 2016, 01:33
GitHub: MHketbi

Re: adding tf.ahk library result in utf error

16 Nov 2016, 13:42

would you like to share with us your code so we can point out your issue.
ahkForWork
Posts: 92
Joined: 28 Mar 2016, 07:59

Re: adding tf.ahk library result in utf error

16 Nov 2016, 13:43

there's an issue at Line 1 in the 'TK.ahk' file that is causing the error.
Ziad El Hachem
Posts: 21
Joined: 29 Aug 2016, 08:19

Re: adding tf.ahk library result in utf error

16 Nov 2016, 13:55

my code is simply:
Loop, Files, d:\*.ini, FR ; courtesy of ahk forum guy!
{
TF_Replace("!" A_LoopFileName, "D:\oldico","D:\newico")
}


and sometimes i do insert only:
#Include D:\Dropbox\AHKscrpt\lib\tf.ahk
(just to test it)

in both cases it makes the error
Guest
Posts: 56
Joined: 17 Oct 2013, 02:32

Re: adding tf.ahk library result in utf error

16 Nov 2016, 14:36

Are you download the correct file? https://raw.githubusercontent.com/hi5/TF/master/tf.ahk there is no "utf" on line one there, unless you copied it and made a mistake. And the file should be saved as tf.ahk not tK.ahk if you are using it in your library (LIB folder) if you #include as in your example it shouldn't matter that much.

I think you may have saved the webpage of TF.ahk not TF.ahk itself as shown in the link above.
Ziad El Hachem
Posts: 21
Joined: 29 Aug 2016, 08:19

Re: adding tf.ahk library result in utf error

16 Nov 2016, 14:42

Guest: exactly! i was wondering what are those <html> doing inside the file!
then i said: probably libraries are written in xml sorta...

many thanks!

Return to “Ask For Help”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], isuckatahk, jly and 31 guests