Same script behaves differently between Win7/10

Get help with using AutoHotkey and its commands and hotkeys
fohrums
Posts: 3
Joined: 07 Sep 2018, 05:39

Same script behaves differently between Win7/10

19 Sep 2018, 17:47

Code: Select all

UPDATED-STATEMENT: [email protected] Post created
I'm trying to yank a name of a file/folder and ending it with an escape. Although i'm able to get it to work on Windows 7, an issue is that I have to use an {Escape} workaround or re-map so it's not traditional. As for Windows 10, it just doesn't work at all where it seems to close the Window and if I try to yank an icon from desktop it removes the icons from view and i'm left unable to right-click desktop to sort icons, so I have to restart my PC. My script is as follows (beginning with escape remap, then the yank file/folder afterwards):

Code: Select all

; THIS SCRIPT BEHAVES DIFFERENTLY BETWEEN WIN7/10
; Win7 works, but needs escape workaround (hence, `!+[`)
; Win10 doesn't work at all

!+[::SendInput, {Escape}

!+c::
  SendInput, {F2} ; rename file
  SendInput, ^a ; select all text
  SendInput, ^c ; yank selected text
  SendInput, !+[ ; escape to normal mode in windows explorer
# SOFTWARE VERSION

* Operating System
+ Windows 7 x64 v6.1.7601
+ Windows 10 x64 v(willpostlater)
* Autohotkey
+ AutoHotkey_1.1.30.00_setup.exe

## PROBLEM

* Unable to produce same result for SendInput, {Escape} on both Windows 7 & Windows 10

## SOLUTION

* None-so-far

#### NOTE

* Windows 7 using {Escape} doesn't work
+ I had to do a workaround by remapping it to another key combination which is `!+[`

Return to “Ask For Help”

Who is online

Users browsing this forum: Bing [Bot], blad4, Google [Bot] and 148 guests