ImageSearch in Chrome not working across different identical laptops

Get help with using AutoHotkey and its commands and hotkeys
dg1
Posts: 4
Joined: 08 Sep 2018, 09:58

ImageSearch in Chrome not working across different identical laptops

24 Sep 2018, 15:01

I have written a script for work that automatically moves the user through a series of web pages by clicking on image buttons as they appear. It is a repetitive task so the images in sequence are always the same. I am tied to Chrome browser by work so have been using ImageSearch to identify the buttons on the screen and click them. This works perfectly on my laptop with different monitors both at home and work.

Other people undertaking the same task have now asked if it would be possible to use the same script but when it is copied to other seemingly identical laptops provided by work, any images within the chrome browser are not identified and the script just sticks in a loop searching for an image it cannot locate. When you examine the images, although very similar there are clear colour differences. Adjusting the *n value for ImageSearch does not help. I have found one other laptop where the script works without having to update the images in anyway. However, I cannot work out what the difference between my laptop and those that don't work is. Nor can I work out what the similarity is between the two laptops where it does work. All the laptops are the same make and model. The chrome versions are different between several of the laptops but on the two that work they are not the same version number.

I have searched fairly extensively about the problems with using ImageSearch across different devices. However, given the fact that the laptops are the same model can anyone suggest how I may be able to get Chrome to display the images identically so that my script will work across multiple devices? The fact that I have two laptops that seem able to do this gives me some hope it might be possible or is it just fluke?

Thanks

Return to “Ask For Help”

Who is online

Users browsing this forum: Google [Bot], nacken012, Rohwedder and 136 guests