Using ImageSearch or PixelSearch with ClassNN: Internet Explorer_Server1

Get help with using AutoHotkey and its commands and hotkeys
timg11
Posts: 20
Joined: 10 Dec 2016, 14:09

Using ImageSearch or PixelSearch with ClassNN: Internet Explorer_Server1

13 Sep 2019, 17:07

I'm using Autohotkey Version 1.1.30.03 on Windows 10 enterprise, 64 bit, version 1809

I'm trying to click on a dialog that is (apparently) built on Internet Explorer.
It has a titlebar and ahk_exe from the host application, but when the mouse is anywhere in the dialog's window, Window Spy shows "Control under Mouse Pointer" as "ClassNN: Internet Explorer_Server1"

There is no visible text or alt text shown in Window Spy anywhere.

The color value in Mouse Position doesn't seem to work correctly. It is either always FFFFFF, or seems to vary randomly even when the mouse is moving in areas of constant color.

There is a unique color at the button I want to click, but PixelSearch doesn't find it.
Likewise, a small image capture of the button is not found when used as the target for ImageSearch.

What approaches and techniques are available in Autohotkey to work with this type of dialog?
User avatar
eblanc
Posts: 71
Joined: 08 May 2019, 14:41

Re: Using ImageSearch or PixelSearch with ClassNN: Internet Explorer_Server1

13 Sep 2019, 17:58

timg11 wrote:
13 Sep 2019, 17:07
I'm using Autohotkey Version 1.1.30.03 on Windows 10 enterprise, 64 bit, version 1809

I'm trying to click on a dialog that is (apparently) built on Internet Explorer.
It has a titlebar and ahk_exe from the host application, but when the mouse is anywhere in the dialog's window, Window Spy shows "Control under Mouse Pointer" as "ClassNN: Internet Explorer_Server1"

There is no visible text or alt text shown in Window Spy anywhere.

The color value in Mouse Position doesn't seem to work correctly. It is either always FFFFFF, or seems to vary randomly even when the mouse is moving in areas of constant color.

There is a unique color at the button I want to click, but PixelSearch doesn't find it.
Likewise, a small image capture of the button is not found when used as the target for ImageSearch.

What approaches and techniques are available in Autohotkey to work with this type of dialog?
Read my tutorial.

You might need to change value to HEX Code. Also sometimes buttons will change color if mouse is over them.

Return to “Ask For Help”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], scriptor2016, songdg and 31 guests