Page 1 of 1

Autocorrect working inconsistently

Posted: 01 Oct 2019, 15:28
by timrh
I've noticed some errors in AutoHotKey operation in the last few days, and I can't tie it down to anything. I've not changed anything in AHK, but have taken app updates etc. I am pretty tech savvy, but Autohotkey syntax eludes me - perhaps I need to deep dive - so most of my AHK stuff is simple hotkeys to send strings. I do use the standard Autocorrect.ahk script and in particular the correction for dual capitalisation. All seems well in Notepad and Libre Office (for example) but in some other apps (like FB messenger or Windows Sticky Notes) it doesn't. My diagnosis is that backspacing seems not to work as expected, so instead of deleting and correcting, it jumbles the word - so typing 'embarass' results not in a correction as would be expected, but in 'embaembar' - it deletes some of the misspelling and adds the correction - but not all of it, as if Windows can't react fast enough to the backspace. So, a bit confused as to what's going on and no real idea where to start looking! The detect consecutive capitals changes something like AMe to Aem as if the characters are being handled out of order.

Apologies if this is stupidity incarnate, but I am definitely missing something important here!

Re: Autocorrect working inconsistently

Posted: 02 Oct 2019, 08:19
by trust_me
Do you use a bluetooth keyboard ? I have similar problems after a recent windows "update" ( win10pro 1903)

Re: Autocorrect working inconsistently

Posted: 02 Oct 2019, 16:59
by timrh
No.. laptop keyboard. Bluetooth mouse - I suppose it's plausible that it's something being hooked by the Logitech drivers (cause I guess they get both mouse and keyboard installed together). I do sense it appeared roundabout the latest Windows 10 update tho'.

Re: Autocorrect working inconsistently

Posted: 03 Oct 2019, 04:33
by Kobaltauge
I don't use the autocorrect.ahk, but I have a few autocorrection and hotstrings in my main script. I have the same issues on few programms. Don't think that is a windows or driver problem. For example in our ticket system Cherwell every hotstring works fine execpt in the "reply woth email" window/editor. This "problem" exist for years and with every "textexpansion" tool not only AHK.

I accepted this issue, with strange input forms. I know this doesn't help you and hope that someone has a solution for us.

Re: Autocorrect working inconsistently

Posted: 03 Oct 2019, 06:47
by red_sun
hi kobaltauge
Don't think that is a windows or driver problem.
I think it is , because I used it for many years but only recently hotstrings used on edge browser are scrambled and I also use ahk code that when a key is hold longer it gives you "uppercase" .When a lowercase string is send some letters are uppercase in Edge browser while in notepad it works fine.

I guess it is a problem between ahk and some window applications.

A strange effect is that when I use a gmail account in the hotstring it is send as [email protected] :shock:

I already changed keyboard to be sure but the problem remains ( thinkcentre Lenovo i5 win10 pro 1903 / 18362.356)

Re: Autocorrect working inconsistently

Posted: 03 Oct 2019, 08:57
by timrh
Thanks for assistance..and at least it's not me. Will have to look at adding exceptions for certain applications then!