Scite not the default editor after installing latest version?

Get help with using AutoHotkey and its commands and hotkeys
kendallb
Posts: 9
Joined: 20 Nov 2019, 16:13
GitHub: kendallb
Contact:

Scite not the default editor after installing latest version?

02 Dec 2019, 13:41

I like to use the Scite editor for my scripts, and I have it installed and it was working with 1.1.31 but I just installed 1.1.32 and now when I click 'edit this script' it brings up notepad? I have .ahk scripts registered to open with Scite and clicking them in explorer brings it up correctly (I had to manually assign that for some reason).

How do I get Autohotkey to use Scite for editing the scripts again?
rakesha002
Posts: 34
Joined: 04 Dec 2017, 00:11

Re: Scite not the default editor after installing latest version?

05 Dec 2019, 10:04

Hi,

Use this script, i had this issue once

Code: Select all

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
; #Warn  ; Enable warnings to assist with detecting common errors.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.
#Persistent
#SingleInstance force
SetTitleMatchMode, Slow
SetTitleMatchMode, 2
SetBatchLines, -1

;;;;;;;;;;;;;Run this script as Administrator to work;;;;;;;;;;;;;
if !A_IsAdmin && !%False%
{
    if A_OSVersion not in WIN_2003,WIN_XP,WIN_2000
    {
        Run *RunAs "%A_AhkPath%" "%A_ScriptFullPath%",, UseErrorLevel
	}
}
RegRead,Ahk_Key,HKCR,.ahk
RegRead,Open_Command,HKCR,%Ahk_Key%\Shell\Edit\Command
MsgBox %Open_Command%
 
Command= %A_ProgramFiles%\AutoHotkey\SciTE\SciTE.exe `%1
RegWrite,REG_SZ,HKCR,%Ahk_Key%\Shell\Edit\Command,,%Command%
exitapp
Hope this helps

Return to “Ask For Help”

Who is online

Users browsing this forum: anhnha, Bing [Bot], Chunjee, Helgef, RubbeH, sobuj53, TAC109, VibinonAHk and 38 guests