Browser / Desktop Discrepancies

Get help with using AutoHotkey and its commands and hotkeys
jeremysawesome
Posts: 1
Joined: 04 Feb 2020, 12:31
GitHub: jeremysawesome

Browser / Desktop Discrepancies

04 Feb 2020, 12:59

This is a question about AutoHotKey. Recently I've noticed a problem specifically involving browser based text areas (like this one). The problem is that my AHK keymappings no longer seem to be communicated to the browser. I've tried the UAC advice from the FAQ but with no success:
https://www.autohotkey.com/docs/FAQ.htm#uac

This problem results in reduced productivity as I have to make special changes to the way I type specifically in web software type environments (example a GitHub Pull Request comment).

Here is a short gif which shows the difference. The keys I press are output in the lower right of the gif.
ahk_issue.gif
ahk_issue.gif (687.88 KiB) Viewed 108 times
The key sequence I use in both cases is:
Shift + Alt+
Shift +

In the gif first I show how they keys work in Notepad. I'm able to use Shift+Alt+ (AHK sends Shift+Home) to highlight from the cursor to the beginning of the line. Then I continue to hold Shift while pressing to highlight only the bits I want to delete. I then press Delete and it does what I want.

The second thing I do in the gif is attempt to do the same thing in the browser. I utilize the same key sequence as mentioned above. (This one is FireFox but Chrome gets the same results). Even though I go through the same key sequence the result is frustratingly different. This is a recent thing, I've only noticed it within the last month or two.

I'll share my simple AHK script below.

Code: Select all

!Left::Send, {Home}
!Right::Send, {End}
!+Up::Send, +{Up}
!+Down::Send, +{Down}
!+Left::Send, +{Home}
!+Right::Send, +{End}
Has anyone had this issue or know how to resolve it? Thank you for your time.

Return to “Ask For Help”

Who is online

Users browsing this forum: Cuadrix, Google [Bot], Rohwedder, vsub and 225 guests