Dead link in CHM-help file

Discuss Autohotkey related topics here. Not a place to share code.
Forum rules
Discuss Autohotkey related topics here. Not a place to share code.
Haswell
Posts: 28
Joined: 21 Feb 2016, 17:11

Dead link in CHM-help file

04 Nov 2019, 05:43

[Moderator's note: Topic moved from Bug Reports.]

Open this page:
https://www.autohotkey.com/docs/Program.htm

Go to the very end of the page.
Here you can find a link "Enable interaction with administrative programs".
I click it and the old AHK-forum thread opens.
I intend to download the script mentioned in this post (I mean "EnableUIAccess.zip").
But I can't because it gives me an error 404 file not found.
Where I can get this script?
Could you provide a working link to that file in chm or update the old post?
User avatar
jmeneses
Posts: 487
Joined: 28 Oct 2014, 11:09
Location: Catalan Republic

Re: Dead link in CHM-help file

04 Nov 2019, 09:15

Hi Haswell it's true the link is broken
look at this thread https://www.autohotkey.com/boards/viewtopic.php?f=76&t=68406&hilit=EnableUIAccess
Donec Perficiam
lexikos
Posts: 6680
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: Dead link in CHM-help file

05 Nov 2019, 06:49

As it says, the link in the documentation is just "For more details". The link in the documentation is clearly not broken (only the download link on the old forum).

This part of the documentation is describing functionality that is built into the AutoHotkey installer. You can find EnableUIAccess() in the installer, as explained in the topic linked by jmeneses above. If you only want to enable UI access for AutoHotkey itself, just use the option in the installer.

Edit: I fixed the link.
Edit: I think it's actually a different script. The new one is meant to be called by the installer, not run.
Last edited by lexikos on 05 Nov 2019, 06:55, edited 2 times in total.
Reason: sigh.

Return to “General Discussion”

Who is online

Users browsing this forum: Jamesbloma and 2 guests