IE erkennt per AHK/Javascript eingefügte Werte nicht

Stelle Fragen zur Programmierung mit Autohotkey

Moderator: jNizM

Milchmann
Posts: 16
Joined: 05 Nov 2016, 08:50

IE erkennt per AHK/Javascript eingefügte Werte nicht

04 Feb 2019, 12:45

Hallo,

leider habe ich wieder mal ein Problem und hoffe auf Hilfe:


Ich füge einen Wert ein:

Code: Select all

pwb.document.GetElementsByName("Text1")[12].Value :="112.12.2019" 
Das Einfügen klappt, wird aber vom Server nicht akzeptiert und löst keine Reaktion aus.
Füge ich das mit Maus oder Tastatur ein, erfolgt mit den gleichen Werten eine Reaktion.

Ich habe es schon versucht mit:

Code: Select all

pwb.document.GetElementsByName("Text1")[12].fireEvent("onchange")
und allen bekannten Eventhandlern, eine Reaktion zu erzeugen. Nichts passiert.
Als nächstes habe ich mich entlang des DOM Baumes nach oben gehangelt und dort auch mit Onchange oder anderen Eventhandlern nichts erreicht.
Auch das erzeugen von eigenen Events brachte keinen Effekt.

Das einzige was funktioniert ist

Code: Select all

ControlSend, Internet Explorer_Server1,{Enter}, ahk_id %hwnd%
Hat jemand noch einen Vorschlag, wie ich per Autohotkey nach dem Einfügen von Werten eine Reaktion des Servers erzwingen kann?

Danke
just me
Posts: 6563
Joined: 02 Oct 2013, 08:51
Location: Germany

Re: IE erkennt per AHK/Javascript eingefügte Werte nicht

05 Feb 2019, 04:01

Moin,

ich habe davon leider kaum Ahnung. Kannst Du auf der Seite ein 'submit' auslösen?
Milchmann
Posts: 16
Joined: 05 Nov 2016, 08:50

Re: IE erkennt per AHK/Javascript eingefügte Werte nicht

14 Feb 2019, 12:00

Sorry, Ich war jetzt eine Woche nicht da.

da kann ich noch mal probieren.

Ich gebe eine Rückmeldung.

Danke

Return to “Ich brauche Hilfe”

Who is online

Users browsing this forum: Google [Bot] and 27 guests