Erstes Zeichen vom Jahr wird oft verschluckt

Stelle Fragen zur Programmierung mit Autohotkey

Moderator: jNizM

frankfragt
Posts: 7
Joined: 02 Mar 2016, 04:57

Erstes Zeichen vom Jahr wird oft verschluckt

20 Oct 2019, 12:10

Guten Tag,

ich bin kein Power-User von AHK, sondern nutze es hauptsächlich zur Vereinfachung des Arbeitsalltages, also mit Autotexten usw.

Unter anderem habe ich in meiner ahk-Datei, die immer mit dem Rechner gestartet wird, das Tastaturkürzel für das Datum (verwende dieses Format immer am Anfang von Dateinamen oder Verzeichnissen) mit <Windows-Taste>+d belegt wie folgt.

Code: Select all

#d::
	send, %A_YYYY%-%A_MM%-%A_DD% 
	return
Das lief auch immer reibungslos, weshalb auch nicht.

Seit einiger Zeit (mir ist unklar, unterwelchen Umständen genau), kommt es öfter vor, dass das erste Zeichen der Jahreszahl, also die 2, nicht gesendet wird. Statt 2019-10-20 wird dann nur 019-10-20 gesendet.

Nun habe ich vor dem send-Befehl ein sleep, 500 eingefügt, in der Hoffnung, dass dieser work-around mir hilft.

Ich werde es jetzt mal länger so testen. Aber irgendwie ist das ja dann doch störend. Hat jemand eine Idee, wie ich das besser lösen kann, ohne 1/2 Sek. Wartezeit?

Danke für Tipps.
KHA
Posts: 166
Joined: 21 Aug 2018, 11:11

Re: Erstes Zeichen vom Jahr wird oft verschluckt

20 Oct 2019, 12:57

Ich benutze das hier:

Code: Select all

#d::
FormatTime, hdatum,, yyyy-M-dd
Send, % hdatum
Return
Aber, dein Script hat bei mir einwandfrei funktioniert.
garry
Posts: 1902
Joined: 22 Dec 2013, 12:50

Re: Erstes Zeichen vom Jahr wird oft verschluckt

20 Oct 2019, 13:33

oder dies

Code: Select all

#d::
Sendinput,{text}%A_YYYY%-%A_MM%-%A_DD% 
return
frankfragt
Posts: 7
Joined: 02 Mar 2016, 04:57

Re: Erstes Zeichen vom Jahr wird oft verschluckt

20 Oct 2019, 14:56

Danke, versuche ich mal beides

Vielleicht liegt es auch daran, dass ich immer noch nicht den Unterschied von send und sendinput verstehe :D

Return to “Ich brauche Hilfe”

Who is online

Users browsing this forum: WPLPHSS and 15 guests