Links from enbedded AHK-code in help forum are incorrect

Discuss issues and requests related with the forum software
User avatar
divanebaba
Posts: 775
Joined: 20 Dec 2016, 03:53
Location: Diaspora

Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 09:45

Hi.
Clicking onto a command, which is embedded into the website directs to wrong address.
Please try to click on the command below and look to which site you are directed

Code: Select all

MsgBox, German teachers fooling foreign children out of education is standard in Germany
Directed to: https://autohotkey.com/docs/MsgBox ; wrong address
instead of: https://autohotkey.com/docs/commands/MsgBox.htm ; correct address

I'm using Chrome-browser and visiting this site from Germany.
tankuser
Posts: 26
Joined: 29 Sep 2013, 16:04

Re: Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 09:51

Something must have recently changed in the docs as those links have worked for years till now. @ragnar can you confirm?
User avatar
Ragnar
Posts: 254
Joined: 30 Sep 2013, 15:25

Re: Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 10:21

This redirection works server-internal, over which I have no control nor knowledge of how it works.

I suppose the cause is the most recent server maintenance, but I'm not sure.
guest3456
Posts: 2555
Joined: 09 Oct 2013, 10:31

Re: Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 10:23

tankuser wrote:@ragnar
do these @ tags work to notify a user? i thought only quoting them would send them a notification

@guest3456 test

tank: i mentioned this same issue in my other thread in this forum. if ragnar thinks its a server side issue, perhaps there used to be an htaccess rewrite rule

tankuser
Posts: 26
Joined: 29 Sep 2013, 16:04

Re: Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 12:02

There have been no maint. on redirects or the .htaccess. I will edit the GeSHi file this weekend to add the missing folder structure. I just wish i knew when or how this changed
guest3456
Posts: 2555
Joined: 09 Oct 2013, 10:31

Re: Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 12:15

tankuser wrote:There have been no maint. on redirects or the .htaccess. I will edit the GeSHi file this weekend to add the missing folder structure. I just wish i knew when or how this changed
as I remember, the codeboxes and [docs] tags always linked to these links:

https://autohotkey.com/docs/MsgBox

and then the browser got redirected to the real link

gregster
Posts: 2799
Joined: 30 Sep 2013, 06:48

Re: Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 12:55

tankuser wrote:There have been no maint. on redirects or the .htaccess. I will edit the GeSHi file this weekend to add the missing folder structure. I just wish i knew when or how this changed
For me it stopped working right after the server maintenance( https://autohotkey.com/boards/viewtopic ... 98#p202298), so I thought it was connected somehow.
User avatar
derz00
Posts: 497
Joined: 02 Feb 2016, 17:54
GitHub: derz00
Location: Middle of the round cube

Re: Links from enbedded AHK-code in help forum are incorrect

27 Feb 2018, 14:01

tankuser wrote:There have been no maint. on redirects or the .htaccess. I will edit the GeSHi file this weekend to add the missing folder structure. I just wish i knew when or how this changed
Might not Lexikos know more about this? I had the impression he set up/maintains the docs.
try it and see
...

Return to “Forum Issues”

Who is online

Users browsing this forum: No registered users and 8 guests