Forum upgraded to phpBB v3.1.x

Discussion about the AutoHotkey Foundation and this website
User avatar
joedf
Posts: 7341
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada
Contact:

Forum upgraded to phpBB v3.1.x

10 May 2015, 09:15

As you may have noticed (i hope you have), the forum has been updated from v3.0.x to phpBB v3.1.x.
There are many reasons for this update, including:
  • First step of the migration (as discussed)
  • many phpBB stability & bug fixes (includes, activation emails, logging out, etc)
  • Offically supported notifications
  • Native mobile support
  • Modern themes
If you have any further comments, opinions, issues about this update, this is the place for it.
Many thanks to Lexikos and TLM for important fixes, also a thanks to all the mods and admins for temporarily handling the spam... (hopefully that will get sorted out) :P
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500 @ 4.00 GHz, 2x8GB G.Skill RipJaws V - DDR4 3280 MHz, NVIDIA GTX 1060 6GB | [About Me] | [ASPDM - StdLib Distribution]
[Populate the AHK MiniCity!] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library] | [About the AHK Foundation]
-_+
Posts: 70
Joined: 06 Dec 2014, 12:43

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 10:56

I like the new layout. The logging out issue seems to be gone for me since the update, so yay!
Gj, joedf.
Randy31416
Posts: 46
Joined: 15 Jan 2014, 19:09

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 11:54

Is there any way to stop the forum blinking at me? Whenever I move the mouse, I get a tooltip or a background changes color or something else gets highlighted. It is hard for me actually to look at the text and read it because stuff keeps happening.
User avatar
joedf
Posts: 7341
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada
Contact:

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 12:16

hmmm, it is possible to get a screenshot? also, what is your browser?
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500 @ 4.00 GHz, 2x8GB G.Skill RipJaws V - DDR4 3280 MHz, NVIDIA GTX 1060 6GB | [About Me] | [ASPDM - StdLib Distribution]
[Populate the AHK MiniCity!] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library] | [About the AHK Foundation]
guest3456
Posts: 2782
Joined: 09 Oct 2013, 10:31

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 13:32

Suggestion:

for the div class="content" of the forum posts, add:

Code: Select all

border-top: 1px solid #e7e7e7;
padding-top: 1em;
Thats the same border color used in the signatures and it makes the text of the post more of the focus instead of it being crammed next to the header/date info

screenshot (default left, suggested right):

Image

guest3456
Posts: 2782
Joined: 09 Oct 2013, 10:31

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 13:38

Re: codeboxes
I think I actually prefer [ codebox] formatting over [ code]

Code: Select all

MyVar := "this is [ codebox ]"
MsgBox %MyVar%

Code: Select all

MyVar := "this is 	[ code ]"
MsgBox %MyVar%
My issues with [ code]
  • The font-family: monospace for

    Code: Select all

    [/c] is using Consolas font and i believe size 13px. But 13px is too large imo and should be 11px or 12px
    [*]I think there should be some indentation of the code block, like how [c][ codebox][/c] has some indentation on both left and right sides
    [*]Needs some padding around it too[/list]
    
    However, [c][ codebox][/c] only seems to work with this exact format: [c][codebox=autohotkey file=asdfasdf.ahk][/c]
    
    Also,
    
    when using the post "Preview" feature, it seems the forum gets confused or outright doesn't display code or codeboxes properly
Last edited by guest3456 on 10 May 2015, 13:54, edited 5 times in total.

User avatar
joedf
Posts: 7341
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada
Contact:

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 13:45

Done, added the line.
change overall_header.html

Code: Select all

<style type="text/css">
/* --- Joe DF START --- */
div.content {
	border-top: 1px solid #e7e7e7;
	padding-top: 1em;
}
/* --- Joe DF STOP  --- */
</style>
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500 @ 4.00 GHz, 2x8GB G.Skill RipJaws V - DDR4 3280 MHz, NVIDIA GTX 1060 6GB | [About Me] | [ASPDM - StdLib Distribution]
[Populate the AHK MiniCity!] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library] | [About the AHK Foundation]
guest3456
Posts: 2782
Joined: 09 Oct 2013, 10:31

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 14:10

Yes, I use the Stylish plugin so I can of course style anything however I want. Just making suggestions that may look better for everyone. They can reject or accept at their will

For example, this [ code] tag looks better:

Image

Changes:

Code: Select all

.codebox_plus_wrap {
  font-size: 0.9em;     /* was previously 1em  */
  margin-left: 1.5em;   /* previously neither left nor right were supplied  */
  margin-right: 1.5em;
}

.codebox_plus_code {
  padding: .5em .7em;   /* was previously .2em .5em  */
}


guest3456
Posts: 2782
Joined: 09 Oct 2013, 10:31

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 14:17

GeekDude wrote:Shouldn't you be using pt for font size?
Pretty sure the standard has moved to em although i don't really know what it means. Most css I see nowadays uses it. And this css already was using 1em so I just lowered it. Googling "css em best practices" and "css font size em vs px" etc brings many results

guest3456
Posts: 2782
Joined: 09 Oct 2013, 10:31

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 14:28

Everyone does it, there must be a reason

Bruttosozialprodukt
Posts: 457
Joined: 24 Jan 2014, 22:28

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 15:14

I really like the new forum design, although it might take some getting used to it for some. :p
I don't like private message icon though. What's the dot/asterisk in the top right corner supposed to mean? I keep clicking it, but there doesn't seem to be anything.
guest3456
Posts: 2782
Joined: 09 Oct 2013, 10:31

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 15:18

I think the default avatar as "a big green question mark" is quite distracting. What do you think about the autohotkey.com/board one ?

Image

User avatar
joedf
Posts: 7341
Joined: 29 Sep 2013, 17:08
Facebook: J0EDF
Google: +joedf
GitHub: joedf
Location: Canada
Contact:

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 16:11

@guest3456 great suggestion, I'll change the default picture, found it distracting too :P
I'll add in that Css padding + font size in later thanks again for your contributions :)

em is the w3c standard, it is relative to the base font size which is usually around 16px, but it is also scaled according to the client area size depending on the device, say mobile, tablet, pc. The base font is considered the "readable size" as defined by the device itself. Etc etc...
Image Image Image Image Image
Windows 10 x64 Professional, Intel i5-8500 @ 4.00 GHz, 2x8GB G.Skill RipJaws V - DDR4 3280 MHz, NVIDIA GTX 1060 6GB | [About Me] | [ASPDM - StdLib Distribution]
[Populate the AHK MiniCity!] | [Qonsole - Quake-like console emulator] | [LibCon - Autohotkey Console Library] | [About the AHK Foundation]
lexikos
Posts: 6668
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 16:50

guest3456 wrote:Re: codeboxes
I think I actually prefer [ codebox] formatting over [ code]
You aren't supposed to be able to use the codebox tag, but I forgot to remove it. (I have done now.) It is the default tag used by the CodeBox Plus extension. I had to heavily modify the extension to get the old code tags to work.

I will fix the styling. At the moment it uses inline styles defined by CodeBox Plus (modified by me) instead of the styles defined for .codebox in the forum stylesheet.
The font-family: monospace for [ code ] is using Consolas font and i believe size 13px. But 13px is too large imo and should be 11px or 12px
It's defined by the browser or the user. On my system (IE, Chrome and Firefox), there is hardly any difference in size between the two code boxes.
when using the post "Preview" feature, it seems the forum gets confused or outright doesn't display code or codeboxes properly
Message previews and posting require different handling. I modified posting to process the 'code' bbcode instead of 'codebox', but the previews worked by replacing the HTML produced by the built-in bbcode processing (and I didn't change that part). I had thought CodeBox Plus didn't handle code boxes in previews/topic review (i.e. adding highlighting and links), but realize now that it does.
Randy31416
Posts: 46
Joined: 15 Jan 2014, 19:09

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 16:51

joedf wrote:hmmm, it is possible to get a screenshot? also, what is your browser?
Image

Firefox. The snapshot above doesn't contain the mouse; it was on the "Forum issues" link next to the big black tooltip popup. Whenever I go to click on a subforum, the black popup occurs. If I run the mouse down the screen over the subforum list in order to get to a subforum of interest I get a blinking stream of appearing and disappearing black bars. Elsewhere on the pages, no matter where mouse is (with few exceptions) I get a yellow tooltip "unread posts". There is no place to rest the mouse.
GeekDude
Posts: 853
Joined: 02 Oct 2013, 22:13

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 18:06

You could rest the mouse somewhere that isn't a subforum bar, for example the empty space on the header and nav bars. If you had read all the posts on a subforum the tooltip would read "No unread posts". The tooltip is a bit redundant I suppose, but there's nothing wrong with that.
guest3456
Posts: 2782
Joined: 09 Oct 2013, 10:31

Re: Forum upgraded to phpBB v3.1.x

10 May 2015, 18:22

lexikos wrote:You aren't supposed to be able to use the codebox tag, but I forgot to remove it. (I have done now.) It is the default tag used by the CodeBox Plus extension. I had to heavily modify the extension to get the old code tags to work.

I will fix the styling. At the moment it uses inline styles defined by CodeBox Plus (modified by me) instead of the styles defined for .codebox in the forum stylesheet.
Thanks looks a lot better now. Only thing: I think expand/collapse is broken


Return to “About This Community”

Who is online

Users browsing this forum: No registered users and 3 guests