v2.1-alpha.11 breaks #Warn Topic is solved

Report problems with documented functionality
eugenesv
Posts: 178
Joined: 21 Dec 2015, 10:11

v2.1-alpha.11 breaks #Warn

Post by eugenesv » 24 May 2024, 04:28

Tried v2.1-alpha.11 and couldn't launch my script, turns out there is something wrong with Warn?

Code: Select all

#Warn All
+1::msgbox(1)
test() {
  En := 'A'
}
when commenting out #Warn All it works

Event viewer shows

Exception code: 0xc0000005
Fault offset: 0x00000000000585c6

Tried launching with/without UIA via Dash

wilkster
Posts: 13
Joined: 15 Jul 2020, 09:43

Re: v2.1-alpha.11 breaks #Warn

Post by wilkster » 24 May 2024, 07:40

I am seeing the same thing with:

Code: Select all

 #Warn All
I isolated it down to the specific warning:

Code: Select all

#Warn LocalSameAsGlobal
as causing the issue. Works fine on prior Alpha versions.

lexikos
Posts: 9721
Joined: 30 Sep 2013, 04:07
Contact:

Re: v2.1-alpha.11 breaks #Warn  Topic is solved

Post by lexikos » 30 May 2024, 21:21

Fixed by v2.1-alpha.12.

Post Reply

Return to “Bug Reports”