Problem with "Control"

Advanced Macro Recorder/Editor.

Moderator: Pulover

Posts: 2
Joined: 03 Nov 2020, 17:08

Problem with "Control"

Post by Lechu » 03 Nov 2020, 17:41

In many software, when I use the tool to grab "Control" - three dots (for example for mouse action 'click'), I have infobox with such text "No control selected. Continue?". If I click "Yes", action/macro don't work. I've tried every possible combination (Title, Class, Process, ID, PID) and name control by myself. No works.

It is possible to make it working? I've attached screenshots, what I've described here.

The software I've tried to are DxO PhotoLab, Luminar, Adobe Camera RAW.
control select.jpg
control select.jpg (49.27 KiB) Viewed 350 times
control select_02.jpg
control select_02.jpg (47.75 KiB) Viewed 350 times
User avatar
Posts: 558
Joined: 29 Sep 2013, 19:51
Location: Brazil

Re: Problem with "Control"

Post by Pulover » 03 Nov 2020, 19:11

Some applications don't expose win32 controls.

From the AutoHotkey documentation:
ControlClick wrote:If this parameter is blank, the target window's topmost control will be clicked (or the target window itself if it has no controls).
You might want to try to set the coordinates and WinTitle, leaving the control blank.
Rodolfo U. Batista
Pulover's Macro Creator - Automation Tool (Recorder & Script Writer)
Posts: 2
Joined: 03 Nov 2020, 17:08

Re: Problem with "Control"

Post by Lechu » 11 Nov 2020, 12:10

Pulover thanks for advice. I've created macro based on image recognition and it works for my needs.
Post Reply

Return to “Pulovers Macro Creator”