Scrambled output in OpenOffice

Get help with using AutoHotkey and its commands and hotkeys
chrisffoulkes
Posts: 2
Joined: 26 Oct 2013, 10:59

Scrambled output in OpenOffice

26 Oct 2013, 11:08

When I use AutoHotkey to send a text string to the OpenOffice wordprocessor, I get a scrambled output – for example, I have a script to type today's date, which today should be displayed as "Saturday 26 October 2013", but I actually get "S 62 yadrutaO3102 rebotc". The script works fine in every other program on my computer, including the OpenOffice spreadsheet. Does anyone have an explanation for this mystery? Is there a solution?
User avatar
tidbit
Posts: 1198
Joined: 29 Sep 2013, 17:15
Location: USA

Re: Scrambled output in OpenOffice

26 Oct 2013, 11:13

Perhaps it sends too fast? Maybe it needs more of a delay.

SetKeyDelay, 150, 50
try adding that at the very top of your script. try raising the value too.
rawr. fear me.
*poke*
Is it December 21, 2012 yet?
chrisffoulkes
Posts: 2
Joined: 26 Oct 2013, 10:59

Re: Scrambled output in OpenOffice

26 Oct 2013, 17:36

Nothing changes with a delay. I can't understand how the key strokes seem to be sent in reverse order.
Leefme
Posts: 90
Joined: 30 Sep 2013, 22:13

Re: Scrambled output in OpenOffice

26 Oct 2013, 19:49

You have not shown what code you are using. Please give us that.

The "send' command has a few variations, have you read the docs about them and tried each?

As a final attempt, you can copy data to the clipboard and then send ^v to paste the data to whatever application is active.
RijulAhuja
Posts: 44
Joined: 30 Sep 2013, 07:29

Re: Scrambled output in OpenOffice

27 Oct 2013, 06:09

May I recommend the Clip() function, to be used for pasting text, rather than sending it ?

Return to “Ask For Help”

Who is online

Users browsing this forum: Arsonistic, paul1965, roysubs and 55 guests