Fault code when installing AHK

Get help with using AutoHotkey and its commands and hotkeys
Posts: 1
Joined: 06 Apr 2018, 09:41

Fault code when installing AHK

06 Apr 2018, 09:44


Ive previously used AHK with great results on WIN7 64bit.

Now that i run WIN10 64bit i get an fault code when installing AHK without understanding what it is. Ive tried turning off the standard antivirus program with WIN10 with no results.

Anyone have any idea? Would be much appreciated!
Capture.PNG (121.4 KiB) Viewed 1371 times
User avatar
Posts: 510
Joined: 19 Nov 2013, 09:15

Re: Fault code when installing AHK

06 Apr 2018, 12:47

You could try to unzip the AutoHotkey_1.1.28.01.zip and manually running the installer.ahk.
Posts: 30
Joined: 02 Feb 2016, 13:24

Re: Fault code when installing AHK

10 Apr 2018, 07:33

I have this very same problem since AHK v 1.1.24. and also "Autohotkey cannot find the program path"...or something similar.

The .exe file looks like a normal .ahk file ( why not a different icon ? ) and that also presented a problem for me.

Now all i do, is copy and paste and mix all the setup files with the backup of a previous version i have and after a while i get it to work, although i told myself after installing v1.1.28 that it`s not worth all the effort for only minor changes.

I can still remember how easy it was to install or update Autohotkey in earlier versions. Just click "install" and it`s done.

But then...who am i to complain ??....after all these years i still enjoy this program tremendously !!!
Posts: 7182
Joined: 30 Sep 2013, 04:07
GitHub: Lexikos

Re: Fault code when installing AHK

10 Apr 2018, 16:31

Clearly, setup does not have permission to write to that file. Check the permissions on the file.

The installer merely does a standard FileCopy and then shows a standard system error message based on A_LastError if it fails. AutoHotkey/setup never changes file permissions, so I assume it is caused by something external to AutoHotkey.
The .exe file looks like a normal .ahk file
Only Ahk2Exe.exe does, not AutoHotkey.exe or the setup file.

Nothing changed in v1.1.24 with regard to how files are installed.
Posts: 30
Joined: 02 Feb 2016, 13:24

Re: Fault code when installing AHK

14 Apr 2018, 11:26

After reading the posts on Winmove not moving, i tried to repair my AHK v1.1.28 and then included the checkmark "with gui access"
Then As the whole program acted weird ( eg compiler chose one icon and stuck with it) , i uninstalled AHK completely and deleted everything associated with it, before installing a fresh AutoHotley v1.1.28 install.

I got the following: The exact problem the OP showed in his screenshot.
Then also access denied to: AutoHotkey A32: AutoHotkey A32: Autohotkey U64
I did install AHK with Admin rights.

This is what i referred to in my post that in earlier versions it was much easier to install AHK, or to change it whenever necessary.( Maybe Win 10 has a lot to do with the current installing problems???.)

I deleted everything once again and used my backup to fix AutoHotkey on my laptop as it was before. :>()

Lexicos, this is NOT meant as disrespect in ANY way. Just my experience installing and Updating AutoHotkey since i bought my laptop in 2016

Return to “Ask For Help”

Who is online

Users browsing this forum: blackjoker, Elgin, Flipeador and 61 guests