AHK Portable Installer v1.10

Post your working scripts, libraries and tools
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.5

17 Mar 2020, 08:17

@hoppfrosch
Ok, are you up for trying the script version so we can pinpoint the problem?

If so, download the master.zip from the repository, unzip, and copy AHK v2 U64 EXE into the script folder and rename to AHK Portable Installer.exe.

If it runs, then we can insert msgbox entries to try and find the error...

EDIT: I'm trying to recreate the problem... no luck yet
User avatar
hoppfrosch
Posts: 406
Joined: 07 Oct 2013, 04:05
GitHub: hoppfrosch
Location: Rhine-Maine-Area, Hesse, Germany
Contact:

Re: AHK Portable Installer v1.5

17 Mar 2020, 08:40

What I just noticed:

Within "AHK Portable Installer U64.exe", above the list where the available AHK versions should be listed there is a message "Registry mismatch" - don't know what this means or whats the impact ...
User avatar
hoppfrosch
Posts: 406
Joined: 07 Oct 2013, 04:05
GitHub: hoppfrosch
Location: Rhine-Maine-Area, Hesse, Germany
Contact:

Re: AHK Portable Installer v1.5

17 Mar 2020, 08:43

Which AHK v2 U64 exe-version? a108?

Edit: Ok, did as you said (downloaded master.zip .... renamed exe ... started) using V2a108

Same behaviour with error
Last edited by hoppfrosch on 17 Mar 2020, 08:47, edited 1 time in total.
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.5

17 Mar 2020, 08:44

@hoppfrosch
The "Registry Mismatch!" is only a way to show that AHK is not installed.

Yes AHK v2 a108.

And what version of windows do you use?
User avatar
hoppfrosch
Posts: 406
Joined: 07 Oct 2013, 04:05
GitHub: hoppfrosch
Location: Rhine-Maine-Area, Hesse, Germany
Contact:

Re: AHK Portable Installer v1.5

17 Mar 2020, 08:48

Using MS Windows 10 Enterprise, Build 16299

----

Edit: we finally figured it out - the problem is caused by different language/localization of OS
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.6 - Update!

17 Mar 2020, 11:55

Changes:
  • FIXED: can't set base folder when running on system with locale NOT set to English due to error
User avatar
hoppfrosch
Posts: 406
Joined: 07 Oct 2013, 04:05
GitHub: hoppfrosch
Location: Rhine-Maine-Area, Hesse, Germany
Contact:

Re: AHK Portable Installer v1.6

18 Mar 2020, 01:54

Works now independent of locale :thumbup:
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.6

18 Mar 2020, 02:03

@hoppfrosch
awesome! thanks for your help :superhappy:
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.7

19 Apr 2020, 04:42

Update 2020/04/19
  • Added my own version of the WTFPL license. I just want to prevent some troll from attempting to being a turd of a human.
  • changed storage to JSON, added library file for JSON
  • removed XML library file, XML code is commented out
NOTE: This release offers no functional updates or improvements. This is just a framework adjustment for going forward. If you do upgrade, you must redefine your settings in the program. There shouldn't be any need to uninstall / reinstall AHK if you choose to implement this upgrade. Just copy over, overwrite, and redefine your settings. There's no need to keep the `Settings.xml` file.
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.8

01 May 2020, 09:42

Update 2020/05/01

Big changes! Please re-read the README on github if you have issues, or post an issue :-P ... here we go:
  • AutoHotkey_H and compiler fully supported now
  • no more need to rename .bin files, or AHK_H EXE files
  • AHK Launcher updated to allow unlimited parallel version of AutoHotkey in Extras tab
  • user specifies AHK version, first-line match string, and associated EXE to run on match in Extras tab
  • appending AHK version to the end of the script file no longer supported
  • included .ahk templates changed to include AHK v1 and v2 lines, all commented out
  • user can still define different custom templates for v1 and v2 if desired
  • fixed several small bugs on startup and when an invalid EXE is specified to run a script
  • improved code to uninstall AHK registry entries, external .reg file no longer needed
  • main EXE now only compiled as 32-bit, writes to 64-bit registry on 64-bit systems
Please post bugs!
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.8 - adding AHK v2 a109

27 May 2020, 07:51

Instructions to add AHK v2 a109

Implementing the latest version of AHK v2 a109 is really easy with AHK Portable Installer. Just download and unzip to the folder specified in the Basics tab. Make sure AHK v2 a109 is contained in its own folder. Also copy WindowSpy.ahk in there as well.

a) On the Extras tab, simply double-click the version of AHK you want to "upgrade" (red arrows)

b) Change the EXE in the popup window (yellow arrow)

c) OPTIONAL: If you want the latest version of AHK v2 a109 to be the default for your system, just double click your preferred version in the main EXE list (blue arrow)
Annotation 2020-05-27 144005.png
Annotation 2020-05-27 144005.png (52.29 KiB) Viewed 1243 times
Please pardon the crazy windows theme I use. It looks different, but functions the same.

If you end up having questions please please ask in this thread.
User avatar
vvhitevvizard
Posts: 405
Joined: 25 Nov 2018, 10:15
Location: Russia

Re: AHK Portable Installer v1.8

29 Jun 2020, 09:29

@TheArkive
; AHKv# as line 1 in the script
just a suggestion: I find myself using slightly different first line commentary. And other ppl scripts might differ from each other, too.
Make the search more fuzzy, try to find any: ";" any symbols "AHK" whitespace separator(s) whitespace "v" "1|2" within 1st line:

Code: Select all

if (s ~= "^;.*AHK[ \t:_,.!>=-]+[vV][12]")
or

Code: Select all

regexmatch(s, "^;.*AHK[ \t:_,.!>=-]?[vV]([12])", m)
if (m[1]=="2")
 ...
if (m[1]=="1")
 ...
Last edited by vvhitevvizard on 29 Jun 2020, 09:39, edited 2 times in total.
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.8

29 Jun 2020, 09:38

@vvhitevvizard
The user defines the regex match in every case. So they can make it as fuzzy as they want. Or they can set the settings (per EXE) to to be an exact match.
User avatar
vvhitevvizard
Posts: 405
Joined: 25 Nov 2018, 10:15
Location: Russia

Re: AHK Portable Installer v1.8

29 Jun 2020, 09:45

@TheArkive
:thumbup:
Also there might be new preprocessor command https://github.com/Lexikos/AutoHotkey_L-Docs/commit/3495cace587e3be99516c656f624be2676bdd6e5
So the regex would be something like:
#requires\sAutohotkey\s[vV]?(\d+)(?:\.\d+)?
and u gotta search some reasonable # of lines (first 4096 bytes or something), not only the first line.

PS: I, for one, don't use ur script tho - I prefer Total Commander's stuff.
Last edited by vvhitevvizard on 29 Jun 2020, 09:53, edited 3 times in total.
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.8

29 Jun 2020, 09:47

vvhitevvizard wrote:
29 Jun 2020, 09:45
u gotta search some reasonable # of lines (first 4096 bytes or something), not only the first line.
Why? I needs to be standardized for simplicity. It's not like you can change AHK code version part way through the script file...
User avatar
vvhitevvizard
Posts: 405
Joined: 25 Nov 2018, 10:15
Location: Russia

Re: AHK Portable Installer v1.8

29 Jun 2020, 09:50

@TheArkive
Well, its kinda impossible to edit all the scripts... especially written by other ppl... So u have to find ways of using fuzzy logic.
AHK preprocessor's commands don't have to follow some order, #requires doesn't have to be in the 1st line of the script...
ofc I'm talking of ur script being future-proof. A user might rewrite all his/her scripts to strictly follow some rules helping to identify its desired AHK version(s).
Last edited by vvhitevvizard on 29 Jun 2020, 09:56, edited 1 time in total.
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.8

29 Jun 2020, 09:56

vvhitevvizard wrote:
29 Jun 2020, 09:50
Well, its kinda impossible to edit all the scripts....
I don't follow... If you have AHK v2 installed on your system, and you want to run AHK v1, then you simply add any variation of ; AHK v1 to line 1 (check regex settings for specifics - modify them any way you like). If the script ever worked at all in any context, it should work in the context of using this program, assuming the settings are properly configured to point to the proper EXE.
User avatar
vvhitevvizard
Posts: 405
Joined: 25 Nov 2018, 10:15
Location: Russia

Re: AHK Portable Installer v1.8

29 Jun 2020, 09:59

What if u get some scripts to assess (to run them and test) written by other ppl? Consider ppl start using #requires preprocessor directive soon.

In other words, ur tool requires a user to re-edit scripts. I'm talking of ur script to analyze a script to be run a bit deeper: u might even start parsing some commands to get an idea whether it requires AHK v2 or v1.
Last edited by vvhitevvizard on 29 Jun 2020, 10:04, edited 1 time in total.
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.8

29 Jun 2020, 10:01

vvhitevvizard wrote:
29 Jun 2020, 09:50
ofc I'm talking of ur script being future-proof. A user might rewrite all his/her scripts to strictly follow some rules helping to identify its desired AHK version(s).
By requiring the first line to be this type of comment, I'm attempting to ensure that the user adds such a comment intentionally. Rather than adding ; AHK v# in some other part of the script, simply meaning to only identify a single part of the script meant for a particular version of AHK. If the AHK language suddenly requires a specific command to be on line 1 of the script document, the I'll figure that out when it happens. Until then, it won't matter, because previously configured AHK EXEs, running scripts of those versions will still function just fine.
User avatar
TheArkive
Posts: 345
Joined: 05 Aug 2016, 08:06
GitHub: TheArkive

Re: AHK Portable Installer v1.8

29 Jun 2020, 10:05

@vvhitevvizard
I think you may be confused about how this script functions. I checked the docs you linked to. If people start using #requires, that won't affect how this program functions. It's up to the user to understand what version of AHK to configure for each script they run.

Return to “Scripts and Functions”

Who is online

Users browsing this forum: DecayTpk, Google [Bot], pgarza and 19 guests